Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: build
    • Labels:
      None

      Description

      Looks like current version of Kite does not support JAVA 8
      [WARNING] Rule 1: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
      Detected JDK Version: 1.8.0-111 is not in the allowed range [1.7.0,1.7.1000}].
      [INFO] ------------------------------------------------------------------------

        Issue Links

          Activity

          evans_ye Evans Ye added a comment -

          Got it. Thanks!

          oflebbe Olaf Flebbe added a comment -

          No, please check with CI Bigtop-trunk-packages. These problems are solved now.

          evans_ye Evans Ye added a comment -

          Oops, looks like CentOS 6 is getting into our line in many aspects, I'm fine to drop it.

          asanjar Amir Sanjar added a comment -

          regression was a build break on centos6, JAVA_HOME not found was the error message..However I didn't have time to investigate. Your recent patches for JAVA 8 might have fixed that problem

          oflebbe Olaf Flebbe added a comment -

          Lets see what the regressions are.

          asanjar Amir Sanjar added a comment -

          setting jdk.verion to 1.8 fixes the problem, but causes regression


            People

            • Assignee:
              oflebbe Olaf Flebbe
              Reporter:
              asanjar Amir Sanjar
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved:

                Development