Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2571

cwr driven updates to the zeppelin juju charm

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1.0
    • Fix Version/s: 1.2.0
    • Component/s: deployment
    • Labels:
      None

      Description

      Zeppelin charm tests in our cloud weather report (cwr) have shown sporadic failures. Some of these seem to be caused by timeouts related to overly complex zeppelin smoke tests:

      http://data.vapour.ws/cwr-tests/results/cs_zeppelin/index.html

      The Zeppelin charm doesn't need a full Hadoop cluster to smoke test it, so don't waste time/resources standing one up. Simplify the tests so we can smoke zeppelin in a reasonable amount of time and move on.

      While we're here, update the readme to be more consistent with other bigtop charms.

        Issue Links

          Activity

          kwmonroe Kevin W Monroe added a comment -

          Recent tests runs with current zeppelin charm look good. Merged.

          Note the failures on some clouds (GCE in particular) are due to the test harness not being able to scp results – not failures in the charm itself.

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/bigtop/pull/155

          kwmonroe Kevin W Monroe added a comment -

          Charm rev4 contains this patch:

          https://jujucharms.com/zeppelin/

          CWR results should be ready Nov 05:

          http://data.vapour.ws/cwr-tests/results/cs_zeppelin/index.html

          githubbot ASF GitHub Bot added a comment -

          GitHub user kwmonroe opened a pull request:

          https://github.com/apache/bigtop/pull/155

          BIGTOP-2571: cwr driven updates to the zeppelin juju charm

          Simplify our smoke test (it's must simpler and faster to smoke zeppelin/spark than it is to smoke zeppelin/hadoop).

          Since zeppelin is based on hadoop-client, we were inheriting the client's 01-basic-deployment.py test, which installs `hadoop-client`. Zeppelin tests don't need hadoop client, so override this test with one that does a simple deployment of just the zeppelin charm.

          While we're in here, make the readme consistent with other bigtop charms and set our application version for `juju status` output.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/juju-solutions/bigtop bug/z-cwr-fixes

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/bigtop/pull/155.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #155


          commit 712f358ea949e267afdc6f6c8cf153dc9d2e6d00
          Author: Kevin W Monroe <kevin.monroe@canonical.com>
          Date: 2016-10-29T16:28:18Z

          simplify amulet test (zeppelin is standalone now); use new action syntax

          commit 337d714218c812fa742d589c77d4f182a51a4e76
          Author: Kevin W Monroe <kevin.monroe@canonical.com>
          Date: 2016-10-29T18:40:08Z

          update readme to be consistent with other bigtop charms; make amulet test use a spark relation (otherwise zepp standalone defaults to yarn, which would require a whole hadooop env to test)

          commit 434f080a143393f0dd1ad056191cd2a89b4e2d77
          Author: Kevin W Monroe <kevin.monroe@canonical.com>
          Date: 2016-11-04T19:41:46Z

          add basic deployment test in addition to smoke test; set app version for juju status



            People

            • Assignee:
              kwmonroe Kevin W Monroe
              Reporter:
              kwmonroe Kevin W Monroe
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development