Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2427

jsvc build not recognizing ARM as valid platform

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.0
    • Component/s: jsvc
    • Labels:
      None

      Description

      Building bigtop-jsvc fails in AARCH64.

      checking C flags dependant on host system type... failed
      configure: error: Unsupported CPU architecture "aarch64"
      make[1]: *** [override_dh_auto_build] Error 1

      dpkg-buildpackage: error: debian/rules build gave error exit status 2
      debuild: fatal error at line 1364:
      dpkg-buildpackage -rfakeroot -D -us -uc -b
      failed
      :bigtop-jsvc-deb FAILED

      FAILURE: Build failed with an exception.

      • Where:
        Script '/ws/packages.gradle' line: 308
      • What went wrong:
        Execution failed for task ':bigtop-jsvc-deb'.

        Activity

        asanjar Amir Sanjar added a comment -
        asanjar Amir Sanjar added a comment -

        Roman/Ganesh
        I have a patch to fix this regression, opening a new JIRA with link to this one, is that the process?

        rvs Roman Shaposhnik added a comment -

        Attaching a patch based on the commit that went upstream.

        ganeshraju Ganesh Raju added a comment -

        Attaching the patch

        v_ganeshraju Ganesh Raju added a comment -

        Submitted a bug with Apache Commons
        https://issues.apache.org/jira/browse/DAEMON-347

        rvs Roman Shaposhnik added a comment -

        Ganesh Raju actually – never mind – looks like we're using the latest jsvc. I guess the only thing left is to verify whether trunk of jsvc is affected and if it is file a JIRA on that side and suggest a patch?

        rvs Roman Shaposhnik added a comment -

        Ganesh, can you please check if the latest version of jsvc suffers from the same issue still?


          People

          • Assignee:
            v_ganeshraju Ganesh Raju
            Reporter:
            v_ganeshraju Ganesh Raju
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development