Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.1.0
    • Component/s: None
    • Labels:
      None

      Description

      Similar to BIGTOP-2232 let's add smoke tests for HCFS

        Activity

        cos Konstantin Boudnik added a comment -

        Here's the fix. Seems to be working just fine.

        cos Konstantin Boudnik added a comment -

        Oops, got setting misplaced. Should be in the test task

        cos Konstantin Boudnik added a comment -

        Come to think of it: running these tests not as hdfs will likely barf for the commands like snapshot where FS superuser privilege is needed. There's still a need to find how to run these tests under different user - we haven't answered it since the original time.

        As an idea - instead of asserting the user we might just skip such tests using assume, when the user wasn't what was expected.

        evans_ye Evans Ye added a comment -

        How about create a super user at puppet side and use it to run all the tests?

        cos Konstantin Boudnik added a comment -

        We do have that very super-user created when the cluster is deployed. In fact, all HDFS layer is ran under that user. The problem is a bit different - we don't need to run all the tests as superuser, just some of them like part of TestDFSCLI. And for this short moment we need to switch the effective user.

        I guess doing this from Gradle, as you mentioned in BIGTOP-2247, would be great - we need to figure out how.
        Thanks for the review - will commit this

        cos Konstantin Boudnik added a comment -

        Committed and pushed to the master


          People

          • Assignee:
            cos Konstantin Boudnik
            Reporter:
            cos Konstantin Boudnik
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development