Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-2190

libprotobuf8 2.5.0 installation fails on ubuntu 14.04 for ppc64le

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.0.1, 1.1.0
    • Component/s: build, docker, toolchain
    • Labels:
      None
    • Environment:

      Ubuntu 14.04 on ppc64le

      Description

      libprotobuf8 is missing from bigtop/slaves:ubuntu-14.04-ppc64le docker image due to package install failure.
      Failure was caused by missing and invalid dependencies required by libprotobuf8_2.5.0-9ubuntu1_ppc64el.deb package installed by bigtop_toolchain.
      After further debugging, it was discovered that libprotobuf8_2.5.0-9ubuntu1_ppc64el.deb was built incorrectly.
      Adding the official Ubuntu protobuf 2.5.0 packages from https://launchpad.net/ubuntu/+source/protobuf/2.5.0-9ubuntu1/+build/5604345 fixed the problem. Not sure why this was not done from beginning . Submitting a patch shortly ..

        Attachments

        1. BIGTOP-2190.2.patch
          1 kB
          Olaf Flebbe
        2. BIGTOP-2190
          1 kB
          Amir Sanjar

          Issue Links

            Activity

              People

              • Assignee:
                asanjar Amir Sanjar
                Reporter:
                asanjar Amir Sanjar
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved: