Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.0
    • Fix Version/s: 1.1.0
    • Component/s: general
    • Labels:
      None

      Description

      Mahout 0.11.1 was released on Nov 6, 2015. Bump the Mahout version in BigTop to 0.11.1

        Issue Links

          Activity

          andrew.musselman Andrew Musselman added a comment -

          Maybe they're just in the mirror list; not aware of a commercial/public filter for that.

          cos Konstantin Boudnik added a comment -

          I've noticed this in the build log

          Downloading: http://repository.mapr.com/maven/com/twitter/parquet-column/1.6.0rc3/parquet-column-1.6.0rc3.jar
          

          what's the reason to use commercial closed repos instead of the public ones?

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman closed the pull request at:

          https://github.com/apache/bigtop/pull/75

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175920838

          Closing

          githubbot ASF GitHub Bot added a comment -

          Github user c0s commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175919512

          This could be closed as the commit is pushed to the upstream

          cos Konstantin Boudnik added a comment -

          Pushed to the master. Thanks Andrew Musselman!

          cos Konstantin Boudnik added a comment -

          Squashing two commits together for the patch

          cos Konstantin Boudnik added a comment -

          Manual package build on our CI was also fine. Committing.

          cos Konstantin Boudnik added a comment -

          Great, will commit this in the morning. Thanks for pushing this all the way though, Andrew Musselman

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175436927

          Builds correctly locally via `$ sudo docker run --rm -v `pwd`:/ws --workdir /ws bigtop/slaves:trunk-centos-7 bash -l -c './gradlew --stacktrace mahout-clean mahout-rpm'`

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175426166

          Alright, adding the .md version to the SPEC for now.

          githubbot ASF GitHub Bot added a comment -

          Github user c0s commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175426108

          Looks like bigtop CI is busy with nightly build, but I have kicked off mahout build here
          http://ci.bigtop.apache.org/job/Bigtop-trunk-packages-manual-component-test/BUILD_ENVIRONMENTS=centos-7,label=docker-slave/
          with the change in the file name. If this works fine - we should be good to go.

          githubbot ASF GitHub Bot added a comment -

          Github user c0s commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175425691

          The deb build is using logic encoded in install_mahout.sh - and that works. We can improve this separately (hint: open a JIRA for that

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175424061

          Good catch; strange it's not a problem with the deb build though. I'll fix it.

          githubbot ASF GitHub Bot added a comment -

          Github user c0s commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175423087

          The reason for the error is in the commit
          347c2f2ec61f6a83e06c00c19d069acaf3a938b7
          README.txt has been renamed to README.md

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175421593

          I can reproduce the error with mahout 0.11.1 and do not get the error with 0.11.0 so this does look like a regression.

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175415108

          I had a successful local build via:

          `$ sudo docker run --rm -v `pwd`:/ws --workdir /ws bigtop/slaves:trunk-centos-7 bash -l -c './gradlew --stacktrace mahout-clean mahout-rpm'`

          What would we look at next?

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175355974

          Will take a look later tonight; that's weird.

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175330871

          Thank you!

          githubbot ASF GitHub Bot added a comment -

          Github user c0s commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175330720

          Ah, makes sense. The patch looks good to me.
          +1 and I will run the build as well before pushing this into the master. Thanks!

          githubbot ASF GitHub Bot added a comment -

          Github user andrewmusselman commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175330146

          All cleared up, those were just not in 0.11.0.

          githubbot ASF GitHub Bot added a comment -

          Github user c0s commented on the pull request:

          https://github.com/apache/bigtop/pull/75#issuecomment-175329074

          Hey Andrew, thanks! What about some of the missing files in the package you've mentioned on the dev@ or JIRA? Is this issue gone away somehow?

          githubbot ASF GitHub Bot added a comment -

          GitHub user andrewmusselman opened a pull request:

          https://github.com/apache/bigtop/pull/75

          BIGTOP-2119: Bump Mahout version to 0.11.1

          Updated mahout version in bigtop.bom, built mahout-pkg, installed .deb, and ran a recommender job as well as checked the spark-shell works.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/andrewmusselman/bigtop BIGTOP-2119

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/bigtop/pull/75.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #75


          commit c888012fd123227469bd0e4176881d0ed99702ac
          Author: Andrew Musselman <akm@apache.org>
          Date: 2016-01-27T01:19:45Z

          BIGTOP-2119: Bump Mahout version to 0.11.1


          andrew.musselman Andrew Musselman added a comment -

          Getting there; think I'll have a patch tomorrow mid-day.

          cos Konstantin Boudnik added a comment -

          Yeah something like this. I have cleaned up the JIRA least already - we still have a few in PA state that needs to be committed and then I'd be all ready to cut RC. Let me know if you need any help and thanks for working on it!

          andrew.musselman Andrew Musselman added a comment -

          I will do what I can this evening and weekend. You hoping to release next weekend?

          cos Konstantin Boudnik added a comment -

          Guys, I want to start working on 1.1 RC as this week is the only spare time I will have for a long while. Please let me know what's going on with this ticket.

          andrew.musselman Andrew Musselman added a comment - - edited

          Could be user error, using the ubuntu-14.04 docker image to run the build, but running on 15.04.

          Scripts for hadoop are missing too after installing that .deb, like start-dfs.sh etc.

          cos Konstantin Boudnik added a comment -

          Most likely copying of these files is missed in bigtop-packages/src/common/mahout/install_mahout.sh

          andrew.musselman Andrew Musselman added a comment -

          I'm not sure the current deb|rpm|yum|apt packaging for mahout is working currently: after installing current mahout-pkg I'm missing some helper scripts from mahout/bin such as `mahout-spark-class.sh` which sets classpath for spark.

          I'll dig in a bit, but any idea where that would be fixed in the build script?

          cos Konstantin Boudnik added a comment -

          There's a possibility that something left laying around under dl/ directory and it gets in the way of downloading the bits. realclean will deal with it.

          andrew.musselman Andrew Musselman added a comment - - edited

          Thanks Evans, realclean instead of allclean seems to work around that problem.

          evans_ye Evans Ye added a comment -

          I can confirm that's exactly the case I encountered in our CI build tasks. I ended up separated the command into two commands: gradle realclean and gradle xxx-pkg, just as what you did. I think at least we have a workaround.

          andrew.musselman Andrew Musselman added a comment -

          I'm still trying to build the mahout package, pasting the dev@ conversation here:

          No, it's not related to new app versions. This happens any time I try (from
          my dev machine while on the corporate network) to build any app that
          downloads its source from the Apache mirror, which for some reason seems to
          be hardcoded to http://apache.osuosl.org.

          What's even weirder is that I have also experienced this off the corporate
          network (usually on our EC2 build nodes) if I run "gradle realclean
          someproject-rpm". That is, if I run the realclean target then some target
          that ends up running a download target, where the download comes from the
          Apache mirror, and I do so in the same invocation of gradle, it will fail
          in this same way. If I run "gradle realclean" then "gradle
          someproject-rpm", it does not fail in the way. This makes even less sense
          to me than the first problem.

          On Thu, Jan 14, 2016 at 4:28 PM Konstantin Boudnik <cos@apache.org> wrote:

          > If a release has been published just recently, then it might not be on all
          > mirrors yet. That's the only explanation I have.
          >
          > Cos
          >
          > On Fri, Jan 15, 2016 at 12:11AM, Jonathan Kelly wrote:
          > > I have noticed errors like this as well. If I add "--stacktrace" to the
          > > arguments, I see that the Apache mirror returned a 403 for the URL. As
          > > Andrew says, doing a wget on the same exact URL works fine. Also, I'm
          > > pretty sure I've noticed that the error only occurs while I'm in the
          > office
          > > on the corporate network or connected to VPN. This makes no sense to me.
          > >
          > > ~ Jonathan
          > >
          > > On Thu, Jan 14, 2016 at 4:04 PM Konstantin Boudnik <cos@apache.org>
          > wrote:
          > >
          > > > Could you please publish your patch to the JIRA? And I suggest to move
          > this
          > > > discussion there as well.
          > > >
          > > > Cheers,
          > > > Cos
          > > >
          > > > On Thu, Jan 14, 2016 at 03:37PM, Andrew Musselman wrote:
          > > > > Even though `wget
          > > > >
          > > >
          > http://apache.osuosl.org//mahout/0.11.0//apache-mahout-distribution-0.11.0-src.tar.gz`
          > <http://apache.osuosl.org//mahout/0.11.0//apache-mahout-distribution-0.11.0-src.tar.gz>
          > > > <
          > http://apache.osuosl.org//mahout/0.11.0//apache-mahout-distribution-0.11.0-src.tar.gz
          > >
          > > > > succeeds, I get this error:
          > > > >
          > > > > $ ./gradlew mahout-download
          > > > > :buildSrc:compileJava UP-TO-DATE
          > > > > :buildSrc:compileGroovy UP-TO-DATE
          > > > > :buildSrc:processResources UP-TO-DATE
          > > > > :buildSrc:classes UP-TO-DATE
          > > > > :buildSrc:jar UP-TO-DATE
          > > > > :buildSrc:assemble UP-TO-DATE
          > > > > :buildSrc:compileTestJava UP-TO-DATE
          > > > > :buildSrc:compileTestGroovy UP-TO-DATE
          > > > > :buildSrc:processTestResources UP-TO-DATE
          > > > > :buildSrc:testClasses UP-TO-DATE
          > > > > :buildSrc:test UP-TO-DATE
          > > > > :buildSrc:check UP-TO-DATE
          > > > > :buildSrc:build UP-TO-DATE
          > > > > :mahout_vardefines
          > > > > :mahout-download
          > > > > Download
          > > > >
          > > >
          > http://apache.osuosl.org//mahout/0.11.0//apache-mahout-distribution-0.11.0-src.tar.gz
          > > > > :mahout-download FAILED
          > > > >
          > > > > Same problem with `gradlew pig-download`; any ideas what's causing
          > it?
          > > >
          >

          cos Konstantin Boudnik added a comment -

          Thanks man. If you stuck at all - ping me or the dev@ and we'll help. Also, here's a decent write-up on how to build trunk without much troubles
          https://cwiki.apache.org/confluence/display/BIGTOP/How+to+build+Bigtop-trunk

          Thanks!

          andrew.musselman Andrew Musselman added a comment -

          I'll take a look, thanks.

          cos Konstantin Boudnik added a comment -

          if anyone on the Mahout team is familiar with the Bigtop you can change the version in bigtop.bom, build packages and test it.
          If not - I will try to find a bit of cycles next week to do it while over at SCALE conference. Thanks

          andrew.musselman Andrew Musselman added a comment -

          Anything the Mahout team can do to help?

          cos Konstantin Boudnik added a comment -

          Is anyone working on this? Looks like we have pretty much all of our issues solved, and are in a good shape to start a release.

          smarthi Suneel Marthi added a comment -

          Mahout 0.11.1 has been built against Spark 1.4.1 and Hadoop 2.4, but is binary compatible with Spark 1.5+ and Spark 1.3.1.

          jayunit100 jay vyas added a comment -

          Thanks sunneel.
          What are the Spark requirements?


            People

            • Assignee:
              andrew.musselman Andrew Musselman
              Reporter:
              smarthi Suneel Marthi
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development