Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1827

Tachyon package name conflict on Debian/Ubuntu

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: debian
    • Labels:
      None
    • Environment:

      Debian

      Description

      Debian and Ubuntu already have a package named "tachyon":

      https://packages.debian.org/sid/tachyon

      Parallel/Multiprocessor Ray Tracing Software

      http://jedi.ks.uiuc.edu/~johns/raytracer/

      which has been in Debian since 2008, and apparently was started in 1994.

      Because this package has a higher version number (0.99~b2+dfsg-0.4) it will always take precedence to the Bigtop "tachyon" package, and on upgrades this will cause chaos.

      Maybe the package should be named tachyon-java or apache-tachyon instead to avoid upgrade problems?

        Issue Links

          Activity

          Hide
          evans_ye Evans Ye added a comment -

          Good catch!
          Correct me if I'm wrong: Tachyon is not an apache project, so maybe we should have a name like bigtop-tachyon or amplab-tachyon.
          How do you think jay vyas?

          Show
          evans_ye Evans Ye added a comment - Good catch! Correct me if I'm wrong: Tachyon is not an apache project, so maybe we should have a name like bigtop-tachyon or amplab-tachyon . How do you think jay vyas ?
          Hide
          jonathak Jonathan Kelly added a comment -

          How about tachyon-dfs or tachyon-fs?

          Show
          jonathak Jonathan Kelly added a comment - How about tachyon-dfs or tachyon-fs?
          Hide
          oflebbe Olaf Flebbe added a comment -

          We already have a name clash: "zookeeper" is contained in debian in an incompatible fashion.

          I would vote to rename to bigtop-tachyon

          Olaf

          Show
          oflebbe Olaf Flebbe added a comment - We already have a name clash: "zookeeper" is contained in debian in an incompatible fashion. I would vote to rename to bigtop-tachyon Olaf
          Hide
          oflebbe Olaf Flebbe added a comment -

          And btw. would should rename RPM too , in order to stay consistent. Objections?

          Show
          oflebbe Olaf Flebbe added a comment - And btw. would should rename RPM too , in order to stay consistent. Objections?
          Hide
          jonathak Jonathan Kelly added a comment -

          I think it seems a little inconsistent to prefix it with "bigtop-" but not to do so with the other packages. This is why I suggested tachyon-dfs or tachyon-fs.

          Show
          jonathak Jonathan Kelly added a comment - I think it seems a little inconsistent to prefix it with "bigtop-" but not to do so with the other packages. This is why I suggested tachyon-dfs or tachyon-fs.
          Hide
          oflebbe Olaf Flebbe added a comment -

          Yep. But how about tachyon-tfs , since this name is been used by tachyon itself ?

          Show
          oflebbe Olaf Flebbe added a comment - Yep. But how about tachyon-tfs , since this name is been used by tachyon itself ?
          Hide
          jonathak Jonathan Kelly added a comment -

          Ah, yes, "tachyon-tfs" might be better than "tachyon-dfs". However, since the 't' in "tfs" stands for Tachyon, "tachyon-tfs" might be somewhat an instance of RAS Syndrome. So then how about "tachyon-fs"?

          Show
          jonathak Jonathan Kelly added a comment - Ah, yes, "tachyon-tfs" might be better than "tachyon-dfs". However, since the 't' in "tfs" stands for Tachyon, "tachyon-tfs" might be somewhat an instance of RAS Syndrome. So then how about "tachyon-fs"?
          Hide
          evans_ye Evans Ye added a comment -

          +1 clearly we need to maintain the consistency.

          Show
          evans_ye Evans Ye added a comment - +1 clearly we need to maintain the consistency.
          Hide
          evans_ye Evans Ye added a comment -

          If some one would like to GUESS the actual name, then I think tachyon-tfs is much easier to guess. Take hadoop-hdfs package as an example, you'll see exactly the same naming rule on both of them. And that's what we're trying to achieve. Thoughts?

          Show
          evans_ye Evans Ye added a comment - If some one would like to GUESS the actual name, then I think tachyon-tfs is much easier to guess. Take hadoop-hdfs package as an example, you'll see exactly the same naming rule on both of them. And that's what we're trying to achieve. Thoughts?
          Hide
          evans_ye Evans Ye added a comment -

          Or Let's ping the tachyon maintainer to make the call:
          David Capwelll, jay vyas, Huamin Chen do you have any thought on the tachyon packaging naming?
          I'm fine if that's not my version being picked. Just want to hear some voice from tachyon community.
          We should get this fixed otherwise we can't have an workable version of tachyon in Bigtop 1.0 release.

          Show
          evans_ye Evans Ye added a comment - Or Let's ping the tachyon maintainer to make the call: David Capwell l, jay vyas , Huamin Chen do you have any thought on the tachyon packaging naming? I'm fine if that's not my version being picked. Just want to hear some voice from tachyon community. We should get this fixed otherwise we can't have an workable version of tachyon in Bigtop 1.0 release.
          Hide
          cos Konstantin Boudnik added a comment -

          Guys, if I don't hear from anyone on Tachyon side about the fix for this one - I will have to drop the component out of the release 1.0

          I am about to cut RC branch tonight and will have to remove this from the BOM unless I hear otherwise.

          Show
          cos Konstantin Boudnik added a comment - Guys, if I don't hear from anyone on Tachyon side about the fix for this one - I will have to drop the component out of the release 1.0 I am about to cut RC branch tonight and will have to remove this from the BOM unless I hear otherwise.
          Hide
          jayunit100 jay vyas added a comment -

          im okay to gut tachyon , i havent tested it recently, and have no cycles to do so at the moment.

          Show
          jayunit100 jay vyas added a comment - im okay to gut tachyon , i havent tested it recently, and have no cycles to do so at the moment.
          Hide
          apurtell Andrew Purtell added a comment -

          Is this just a packaging naming issue? If so I vote we make an executive decision and go with Evans Ye's suggestion of tachyon-tfs. No need to drop it, unless it is further broken in some deeper way.

          Show
          apurtell Andrew Purtell added a comment - Is this just a packaging naming issue? If so I vote we make an executive decision and go with Evans Ye 's suggestion of tachyon-tfs . No need to drop it, unless it is further broken in some deeper way.
          Hide
          cos Konstantin Boudnik added a comment -

          Either way is fine. If someone can contribute the fix and test it - I am happy to keep it in 1.0

          Show
          cos Konstantin Boudnik added a comment - Either way is fine. If someone can contribute the fix and test it - I am happy to keep it in 1.0
          Hide
          cos Konstantin Boudnik added a comment -

          Looks like there's more: BIGTOP-1824, BIGTOP-1828, BIGTOP-1829

          Show
          cos Konstantin Boudnik added a comment - Looks like there's more: BIGTOP-1824 , BIGTOP-1828 , BIGTOP-1829
          Hide
          apurtell Andrew Purtell added a comment -

          Meh.., +1 to drop from 1.0. As you say it's on master if a maintainer shows up.

          Show
          apurtell Andrew Purtell added a comment - Meh.., +1 to drop from 1.0. As you say it's on master if a maintainer shows up.
          Hide
          evans_ye Evans Ye added a comment -

          How about give me a shot on renaming the package?
          I've tested those 3 JIRAs on centos cluster. Running a taychon job on it works well.
          To me the tachyon stuff only need a final piece which is to fix its naming.

          Show
          evans_ye Evans Ye added a comment - How about give me a shot on renaming the package? I've tested those 3 JIRAs on centos cluster. Running a taychon job on it works well. To me the tachyon stuff only need a final piece which is to fix its naming.
          Hide
          cos Konstantin Boudnik added a comment -

          Sure. Please do.
          I will branch out 1.0 and if the Tachyon is fixed in the next a couple of days I will just merge the fixes in. Thanks!

          Show
          cos Konstantin Boudnik added a comment - Sure. Please do. I will branch out 1.0 and if the Tachyon is fixed in the next a couple of days I will just merge the fixes in. Thanks!
          Hide
          evans_ye Evans Ye added a comment -

          OK. The patch is ready, finally.
          This patch not only rename the package name from tachyon to tachyon-tfs, but also fix some deb packaging issue:

          • service scripts are not installed
          • /var/run/tachyon directory not being created, which cause the daemon failed to start

          In order to get all the tachyon stuff all fixed.
          We need to apply other patches before this:
          BIGTOP-1824 --> BIGTOP-1829 --> BIGTOP-1827

          I've tested this on centos and debian cluster. It works well on both.

          Show
          evans_ye Evans Ye added a comment - OK. The patch is ready, finally. This patch not only rename the package name from tachyon to tachyon-tfs, but also fix some deb packaging issue: service scripts are not installed /var/run/tachyon directory not being created, which cause the daemon failed to start In order to get all the tachyon stuff all fixed. We need to apply other patches before this: BIGTOP-1824 --> BIGTOP-1829 --> BIGTOP-1827 I've tested this on centos and debian cluster. It works well on both.
          Hide
          cos Konstantin Boudnik added a comment -

          I have linked these issues via "is blocked by" to enforce the dependency constraints.

          Show
          cos Konstantin Boudnik added a comment - I have linked these issues via "is blocked by" to enforce the dependency constraints.
          Hide
          cos Konstantin Boudnik added a comment -

          +1 the patch looks good.

          Show
          cos Konstantin Boudnik added a comment - +1 the patch looks good.
          Hide
          cos Konstantin Boudnik added a comment -

          Pushed to the master. Thanks Evans!

          Show
          cos Konstantin Boudnik added a comment - Pushed to the master. Thanks Evans!

            People

            • Assignee:
              evans_ye Evans Ye
              Reporter:
              erich.schubert Erich Schubert
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development