Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: deployment
    • Labels:
      None

      Description

      Looks like puppet deployment doesn't work on Ubuntu. It fails in site.xml:33 with the following error message:

      Debug: hiera(): Looking for data source common
      Debug: hiera(): Cannot find datafile /var/lib/hiera/common.yaml, skipping
      Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Could not find declared class apt at /ws/bigtop-deploy/puppet/manifests/site.pp:33 on node bigtop1.docker
      Wrapped exception:
      Could not find declared class apt
      Error: Puppet::Parser::AST::Resource failed with error ArgumentError: Could not find declared class apt at /ws/bigtop-deploy/puppet/manifests/site.pp:33 on node bigtop1.docker
      

        Issue Links

          Activity

          cos Konstantin Boudnik added a comment -

          Evans Ye, could you please look at it? May something is missing on my system like an extra module?

          cos Konstantin Boudnik added a comment - - edited

          Clearly, running puppet module install puppetlabs-apt solves the issue, so it needs to be documented and gralde's toolchain-puppetmodules needs to be updated as well.

          evans_ye Evans Ye added a comment -

          Hey @cos, indeed that should be documented in the puppet's README. I'll update the toolchain as well.

          evans_ye Evans Ye added a comment -

          Created a JIRA BIGTOP-1822 to implement apt installation in bigtop_toolchain. I'll upload another patch here to have README updated since this JIRA it's more like to be caused by missing documentation.

          evans_ye Evans Ye added a comment -

          upload a patch which trys to explain things more clearly.

          cos Konstantin Boudnik added a comment -

          +1 and committed/pushed. Thanks Evans!

          BTW, for documentation patches we have CTR policy in place - you don't need to wait for anyone to review it upfront.


            People

            • Assignee:
              evans_ye Evans Ye
              Reporter:
              cos Konstantin Boudnik
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development