Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: build
    • Labels:
      None

      Description

      ++ JDK_VERSION=1.7
      ++ SCALA_VERSION=2.10.3
      ++ ZOOKEEPER_VERSION=3.4.5
      ++ HADOOP_VERSION=2.6.0
      ++ GRIDGAIN_HADOOP_VERSION=6.5.6
      ++ HBASE_VERSION=0.98.10.1
      ++ PIG_VERSION=0.14.0
      ++ HIVE_VERSION=1.1.0
      ++ TEZ_VERSION=0.6.0
      ++ SQOOP_VERSION=1.4.5
      ++ SQOOP2_VERSION=1.99.4
      ++ OOZIE_VERSION=4.0.1
      ++ MAHOUT_VERSION=0.9
      ++ FLUME_VERSION=1.5.2
      ++ GIRAPH_VERSION=1.1.0
      ++ HUE_VERSION=3.7.1
      ++ DATAFU_VERSION=1.0.0
      ++ SOLR_VERSION=4.9.0
      ++ CRUNCH_VERSION=0.10.0
      ++ SPARK_VERSION=1.2.0
      ++ PHOENIX_VERSION=4.2.2
      ++ BIGTOP_GROOVY_VERSION=2.3.8
      ++ BIGTOP_UTILS_VERSION=1.0.0
      ++ BIGTOP_JSVC_VERSION=1.0.15
      ++ BIGTOP_TOMCAT_VERSION=6.0.36
      ++ TACHYON_VERSION=0.6.0
      ++ KAFKA_VERSION=0.8.1.1
      + mvn -q clean install -DskipTests -Dhadoop.version=2.6.0 -Dmaven.repo.local=/home/olaf/.m2/repository
      [ERROR] Failed to execute goal com.mycila:license-maven-plugin:2.9:check (default) on project tachyon-parent: Some files do not have the expected license header -> [Help 1]
      [ERROR] 
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR] 
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
      

        Activity

        jayunit100 jay vyas added a comment -

        Huamin Chen You're tachyon project missing the license headers it looks like ?

        chenh Huamin Chen added a comment -

        that's odd, I didn't see this problem. How to reproduce it? Thanks

        oflebbe Olaf Flebbe added a comment -

        Seems like this is broken only on debian/ubuntu systems.

        gradle tachyon-clean
        gradle tachyon-deb
        
        chenh Huamin Chen added a comment -

        thanks, will investigate deb package.

        chenh Huamin Chen added a comment -

        sorry for taking long - deb build environment took me a while to setup.
        Olaf Flebbe the offending file is build/tachyon/deb/tachyon-0.6.0/debian/install_tachyon.sh which is under debian, but debian directory is not part of tachyon source. Do you know how this directory is copied into tachyon source?

        oflebbe Olaf Flebbe added a comment -

        Huamin Chen packages.gradle does copy everything from bigtop-packages/src/common/tachyon and bigtop-packages/src/deb/tachyon to the debian subfolder. This is part is hardcoded in debhelper and debuild and cannot be changed. In contrast these files are one directory up in rpmbuild. If you need this file one directory up, you can copy it in debian/rules (its a makefile, btw)

        oflebbe Olaf Flebbe added a comment -

        For instance:

        diff --git a/bigtop-packages/src/deb/tachyon/rules b/bigtop-packages/src/deb/tachyon/rules
        index 2b0cb04..dd17f88 100755
        --- a/bigtop-packages/src/deb/tachyon/rules
        +++ b/bigtop-packages/src/deb/tachyon/rules
        @@ -27,6 +27,7 @@ export DH_OPTIONS
                dh $@
         
         override_dh_auto_build:
        +       cp debian/install_tachyon.sh .
                # we'll just use the build from the tarball.
                bash debian/do-component-build -Dmaven.repo.local=${HOME}/.m2/repository
        
        chenh Huamin Chen added a comment -

        we think much alike, i just mv so get it out of debian instead of cp

        chenh Huamin Chen added a comment -
        diff --git a/bigtop-packages/src/deb/tachyon/rules b/bigtop-packages/src/deb/tachyon/rules
        index 2b0cb04..9804796 100755
        --- a/bigtop-packages/src/deb/tachyon/rules
        +++ b/bigtop-packages/src/deb/tachyon/rules
        @@ -28,10 +28,11 @@ export DH_OPTIONS
         
         override_dh_auto_build:
                # we'll just use the build from the tarball.
        +       mv debian/install_tachyon.sh debian/../../install_tachyon.sh
                bash debian/do-component-build -Dmaven.repo.local=${HOME}/.m2/repository
         
         override_dh_auto_install:
        -       bash -x debian/install_tachyon.sh \
        +       bash -x debian/../../install_tachyon.sh \
             --build-dir=build \
             --bin-dir=/usr/bin \
             --data-dir=/usr/share \
        
        githubbot ASF GitHub Bot added a comment -

        GitHub user rootfs opened a pull request:

        https://github.com/apache/bigtop/pull/14

        BIGTOP-1781 relocate deb files out of tachyon source

        You can merge this pull request into a Git repository by running:

        $ git pull https://github.com/rootfs/bigtop 1781

        Alternatively you can review and apply these changes as the patch at:

        https://github.com/apache/bigtop/pull/14.patch

        To close this pull request, make a commit to your master/trunk branch
        with (at least) the following in the commit message:

        This closes #14


        commit a2aea12050172baca62220d091f9814596aea07c
        Author: Huamin Chen <hchen@redhat.com>
        Date: 2015-04-01T18:57:15Z

        BIGTOP-1781 relocate deb files out of tachyon source


        chenh Huamin Chen added a comment -

        Olaf Flebbethis patch passed on me.

        oflebbe Olaf Flebbe added a comment -

        Why do you move the file out of the build directory ?

        debian/../install_tachyon.sh should be sufficient?

        chenh Huamin Chen added a comment - - edited

        No, the directory structure is output/tachyon/tachyon-0.6.0/debian/. As long as the file in tachyon, maven will complain. The patch moves the file out of tachyon and resolves this problem.

        oflebbe Olaf Flebbe added a comment - - edited

        But why does it not complain on RPM Systems ? This file is located in tachyon there, too. And btw, can we simply fix this file by adding for instance an Apache license header?

        chenh Huamin Chen added a comment -

        this file is not tachyon source and not placed inside the tachyon source tree during rpm build so it was not causing trouble for rpm build.

        and as you can see, the license header is indeed there.

        oflebbe Olaf Flebbe added a comment -

        I've looked into the license checking plugin... It is a little bit insane, since it does not recognize Apache 2 license text correctly.

        I propose to exclude the debian directory from checking. Patch appended.

        chenh Huamin Chen added a comment -

        worked for me. just a question, why this change?

        diff --git a/bigtop-packages/src/deb/tachyon/control b/bigtop-packages/src/deb/tachyon/control
        index 96e4677..38a5198 100644
        --- a/bigtop-packages/src/deb/tachyon/control
        +++ b/bigtop-packages/src/deb/tachyon/control
        @@ -18,7 +18,7 @@ Section: misc
         Priority: extra
         Maintainer: Huamin Chen <hchen@redhat.com>
         Build-Depends: debhelper (>= 7.0.50~)
        -Standards-Version: 0.5.0
        +Standards-Version: 3.9.4
         Homepage: http://tachyon-project.org
         
         Package:  tachyon
        
        oflebbe Olaf Flebbe added a comment -

        Ok. not functionally needed.

        A cosmetic change, since this file is valid for the current 3.9.4 debian packaging instructions. AFAIK there was never a 0.5.0 version

        oflebbe Olaf Flebbe added a comment -

        A downside from moving the install-tachyon.sh out of the build environment would be that tachyon-clean may not remove it.

        chenh Huamin Chen added a comment -

        LGTM

        jayunit100 jay vyas added a comment - - edited

        https://github.com/apache/bigtop/pull/14 Huamin Chen looks like your PR didnt trigger the JIRA.

        See https://github.com/apache/bigtop/pull/13 as an example of a bigtop commit message which should trigger JIRA attachment.

        If it still doesn't trigger, file a jira w/ INFRA-**** and theyll fix it for you.

        oflebbe Olaf Flebbe added a comment -

        jay vyas FYI: I committed a different patch (the one attached to this ticket) The github pull request is now obsolete.

        mxs mayxine added a comment -

        Hi, alluxio-1.2.0, ubuntu14.04 , still has this exception, I can not build it.

        [INFO] ------------------------------------------------------------------------
        [ERROR] Failed to execute goal com.mycila:license-maven-plugin:2.9:check (default) on project alluxio-parent: Some files do not have the expected license header -> [Help 1]
        org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.mycila:license-maven-plugin:2.9:check (default) on project alluxio-parent: Some files do not have the expected license header
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:216)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:317)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:152)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:555)
        at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:214)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:158)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:497)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
        Caused by: org.apache.maven.plugin.MojoExecutionException: Some files do not have the expected license header
        at com.mycila.maven.plugin.license.LicenseCheckMojo.execute(LicenseCheckMojo.java:68)
        at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:106)
        at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
        ... 19 more

        mxs mayxine added a comment -

        how to resolve it ?

        mxs mayxine added a comment -

        can not build it


          People

          • Assignee:
            chenh Huamin Chen
            Reporter:
            oflebbe Olaf Flebbe
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development