Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1513

FailureExecutor.groovy is in the wrong module, causing compiler errors.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: tests
    • Labels:
      None

      Description

      Getting the following compiler error:
      [ERROR] /ws/bigtop-tests/test-artifacts/hadoop/src/main/groovy/org/apache/bigtop/itest/hadoop/mapreduce/TestHadoopExamples.groovy:[160,39] 2. ERROR in /ws/bigtop-tests/test-artifacts/hadoop/src/main/groovy/org/apache/bigtop/itest/hadoop/mapreduce/TestHadoopExamples.groovy (at line 160)

      It seems FailureExecutor cannot be found because it is in the wrong directory In bigtop.

      Currently in:
      bigtop/bigtop-tests/test-artifacts/longevity/src/main/groovy/org/apache/bigtop/itest/iolongevity/FailureExecutor.groovy

      Needs to be moved to:
      bigtop-test-framework/.../failures/FailureExecutor

      1. BIGTOP-1513.patch
        7 kB
        Konstantin Boudnik

        Issue Links

          Activity

          dawson.choong Dawson Choong added a comment - - edited

          FailureExecutor.groovy is in the wrong module.

          jayunit100 jay vyas added a comment -

          Hi Dawson Choong - how do you feel about updating the smoke-tests.sh script in bigtop-deploy w/ a failure executor option as well (i.e. smoke-tests-failures.sh) ?
          That will give us a concrete and automated way of testing this feature.

          jayunit100 jay vyas added a comment -

          To verify the fix, simply run {{ mvn clean install -DskipTests -DskipITs -f bigtop-tests/test-artifacts/pom.xml }} . That is a easy reproducer of the bug.

          dawson.choong Dawson Choong added a comment -

          jay vyas Sure thing. However, it will be a little while before I can get to it. Busy with some other stuff at the moment!

          jayunit100 jay vyas added a comment -

          okay maybe i can look at it in the meantime

          cos Konstantin Boudnik added a comment -

          Let's fix the compilation issue first. Adding a new smoke test can be done any time, no?

          cos Konstantin Boudnik added a comment -

          Any progress on this? Tests are still broken.

          jayunit100 jay vyas added a comment - - edited

          Konstantin Boudnik hey ! sorry, i will fix this tonite. thanks for reminding ! update i have a minute, looking into it now !

          cos Konstantin Boudnik added a comment -

          Here's the patch - it fixes the compilation issue

          jayunit100 jay vyas added a comment -

          okay ! heres a patch

          cos Konstantin Boudnik added a comment -

          You're 30 minutes late Looks like your patch is essentially the same as one I posted earlier. +1 - please commit.

          jayunit100 jay vyas added a comment -

          Konstantin Boudnik deleted my attachment for simplicity. testing yours now

          jayunit100 jay vyas added a comment - - edited

          ha ! I keep missing you. IM testing yours now
          then i will commit it when i go home (no apache key on my laptop right now).

          jayunit100 jay vyas added a comment -

          +1 vice versa, yours fixes it as well. like i said, i deleted my patch , will commit yours tonite unless u beat me to it

          cos Konstantin Boudnik added a comment -

          Thanks for the review, Jay. I will commit it now.

          cos Konstantin Boudnik added a comment -

          Committed and pushed as
          7d406ee..d6c5f77 HEAD -> master

          jayunit100 jay vyas added a comment - - edited

          FailureExecutor import breaks smoke-tests ... will create a JIRA for that.


            People

            • Assignee:
              cos Konstantin Boudnik
              Reporter:
              dawson.choong Dawson Choong
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development