Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: tests
    • Labels:
      None

      Description

      Lets

      • add a self contained standalone hive validation into smoke-tests which
      • doesnt rely on multiple text files, bash diffs, and other stuff in the relatively complex test-artifacts tests.

        Activity

        jayunit100 jay vyas added a comment -

        Okay ! Heres a simple hive smoke test that any idiot can run and debug. let me know if it Looks okay?

        jayunit100 jay vyas added a comment -

        hi folks.

        ... can someone take a quick look so i can push this in? ... then i will proceed with BIGTOP-1449 so we have an automated RC tester ready to go with 0.8 release !

        rvs Roman Shaposhnik added a comment -

        In general this looks fine. Quick question: bigtop-tests/smoke-tests/hive/passwd.ql shouldn't it be under resources folder or something? Or are we not using a standard java-based approach to managing extra files with Groovy-based smokes?

        jayunit100 jay vyas added a comment -

        Hi roman.. I wasn't imposing a directory hierarchy... Here is why:

        Resources has value w maven, because they are bundled with the compiled artifacts...
        But These smoke-tests tests are run from source , for maximum usability, hack ability, and simplicity ...
        So the "resources" dir has less value (there is no jar packaging going on).

        Makes sense?

        jayunit100 jay vyas added a comment -

        hi Roman Shaposhnik any other comments or ok to proceed and push it through ? im going to use this in the RC autovalidator which i really would like to get done by sunday if possible!

        jayunit100 jay vyas added a comment - - edited

        hi folks. so... Okay to push in Roman Shaposhnik ? I really would like to build a Release candidate autovalidator using this simple and fast tests... (now that its been confirmed that the smoke-tests can quickly expose bugs in the RPMS — without needing to run and compile the full maven test suite (i.e. bug BIGTOP-1453)....

        plinnell Peter Linnell added a comment -

        I'm good with pushing this patch if you have tested it locally.

        jayunit100 jay vyas added a comment -

        Yup ! Tested... So is that a +1? If so I'll push

        plinnell Peter Linnell added a comment -

        +1 Go ahead

        jayunit100 jay vyas added a comment -

        done ! now onto BIGTOP-1449 (will use these tests to validate the release candidate) and soon after we will need to tackle BIGTOP-1450 (we still need to clean up the {{ test-artifacts }} for those running the full hive battery )

        This will provide a simple and easy to debug hive test, for now, which anyone can run and debug.


          People

          • Assignee:
            jayunit100 jay vyas
            Reporter:
            jayunit100 jay vyas
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development