Details

    • Type: Sub-task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.8.0
    • Fix Version/s: 1.0.0
    • Component/s: tests
    • Labels:
      None

      Description

      BIGTOP-282 removed a dataset that the basic hive smoke test was using. As a result, running the basic smoke-test fails even though hive may be set-up properly.

      The patch uses an existing test dataset to run a very basic test.

      1. BIGTOP-1392-3.patch
        5 kB
        josh baer
      2. BIGTOP-1392-2.patch
        5 kB
        josh baer
      3. BIGTOP-1392.patch
        2 kB
        josh baer

        Issue Links

          Activity

          cos Konstantin Boudnik added a comment -

          I have noticed this line in the top-level smoke-tests build.gradle

              //todo, add back in 'basic' after BIGTOP-1392 .
          

          So, shall it be addressed now?

          jayunit100 jay vyas added a comment -

          commited...

          jayunit100 jay vyas added a comment -

          +1, thanks josh. Im commiting now !

          josh baer now the next step will be BIGTOP-1450 - figuring out how to clean up the rest of the hive tests.

          If Any feedback on how we should do that , keep us posted.

          jbx josh baer added a comment -

          This should fix the merge issue. Let me know if you want help on some of the other Hive tests.

          jbx josh baer added a comment -

          Updating patch

          jayunit100 jay vyas added a comment -

          Excellent. Thanks.!

          jbx josh baer added a comment -

          jay vyas sure, I'll upload a new patch

          jayunit100 jay vyas added a comment -

          hi josh baer still interested in hellping with this patch ?

          jayunit100 jay vyas added a comment -

          josh baer the patch looks like it fixes the error, however, it doesnt apply. some minor differences between the filter file it seems maybe. looking into it

          jayunit100 jay vyas added a comment - - edited

          confirmed that basic test failing. josh baer . took me a while to get around to this ! im going to apply this now and if it fixes ill definetly commit. its a major fix !

          jayunit100 jay vyas added a comment -

          i havent been able to review this and wont be (dont have my laptop with me much right now , out for the week.) im moving to 0.9.

          for some reason hive basic tests pass for me last time i ran them i think, will have to double check ?

          cos Konstantin Boudnik added a comment -

          jay vyas - is it going to be committed? I have branched off 0.8.0 release, but if the tests are broken I am willing to take it in. Please commit or move this ticket to 0.9.0

          jbx josh baer added a comment -

          Replaced additional code that reflected the previous table/dataset.

          jbx josh baer added a comment -

          I actually need to fix one more thing to ensure it works with multiple users. Will submit updated patch soon.

          jayunit100 jay vyas added a comment - - edited

          I agree. Okay +1 to this patch, i will commit it later. thanks josh baer

          jbx josh baer added a comment -

          jay vyas Yep, it was tested on two of our clusters and passes without issues now.

          I see that you added the bigpetstore code for the generated data case, and I could probably modify this test to use it, but perhaps it would be better to convert everything at once so the smoke tests are consistent?

          jayunit100 jay vyas added a comment -

          looks sensible josh baer. I remember that those data sets were moved around, and that indeed broke a few things. I think we should slowly move to generating all of our test data, especially for scenarios like this. but for now this is a good patch to keep hive tests working.

          Have you tested this patch to confirm it works?

          jbx josh baer added a comment -

          This is a very basic test. Tested on a small cluster.

          Apologies if I made a mistake somewhere in the process-- my first patch for the Apache project.


            People

            • Assignee:
              jbx josh baer
              Reporter:
              jbx josh baer
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development