Bigtop
  1. Bigtop
  2. BIGTOP-1163

puppet apply shows db init error if the oozie server is already running

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 0.8.0
    • Component/s: deployment
    • Labels:
      None

      Description

      When deploying hadoop with bigtop's puppet scripts, it will output error message like below If the oozie server is already running.

      debug: Exec[Oozie DB init](provider=posix): Executing '/etc/init.d/oozie init'
      debug: Executing '/etc/init.d/oozie init'
      err: /Stage[main]/Hadoop_head_node/Hadoop-oozie::Server[oozie server]/Exec[Oozie DB init]/returns: change from notrun to 0 failed: /etc/init.d/oozie init returned 1 instead of one of [0] at /home/vagrant/bigtop/bigtop-deploy/puppet/modules/hadoop-oozie/manifests/init.pp:46
      notice: /Stage[main]/Hadoop_head_node/Hadoop-oozie::Server[oozie server]/Service[oozie]: Dependency Exec[Oozie DB init] has failures: true
      warning: /Stage[main]/Hadoop_head_node/Hadoop-oozie::Server[oozie server]/Service[oozie]: Skipping because of failed dependencies
      

        Activity

        Evans Ye created issue -
        Evans Ye made changes -
        Field Original Value New Value
        Status Open [ 1 ] Patch Available [ 10002 ]
        Labels patch
        Evans Ye made changes -
        Labels patch
        Evans Ye made changes -
        Attachment BIGTOP-1163.1.patch [ 12618943 ]
        Evans Ye added a comment -

        Allow me to explain this clearly.
        This bug will not be introduced while provisioning a new cluster.
        The problem here is that for an existing running cluster, you have oozie db running when you try to apply some changes like configurations or components by running puppet apply again. At that moment you'll get an error shows that Exec[Oozie DB init] failed, which will be sort of confusing since we don't know what if there is actually an error occurred in my environment or not.

        Here's the reproduce steps using vagrant-puppet:

        1.) specify oozie to be deployed in the cluster

        ...
        jdk_package_name,java-1.7.0-openjdk-devel.x86_64
        components,hadoop,hbase,oozie
        EOF
        ...
        

        2.) Spin up the cluster, which will succeed

        $ ./startup.sh --cluster
        

        3.) run puppet apply again

        $ vagrant provision --provision-with puppet
        

        This will introduce the problem.

        Evans Ye made changes -
        Affects Version/s 0.7.0 [ 12324362 ]
        Affects Version/s 0.4.0 [ 12318889 ]
        Evans Ye made changes -
        Assignee Evans Ye [ evans_ye ]
        Konstantin Boudnik added a comment -

        If this is still an issue? If so - I will commit the patch, as it seems to be sane. Evans Ye, could you please verify?

        Evans Ye added a comment -

        Hi Konstantin Boudnik, I've test the recipes again based on my reproduce steps to verify the issue and also the patch.
        The issue can still be reproduced, while it can be fixed by applying the patch.
        So I think it's pretty much ok to be committed.

        Konstantin Boudnik added a comment -

        Committed, Thanks Evans!

        Konstantin Boudnik made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Evans Ye
            Reporter:
            Evans Ye
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development