Uploaded image for project: 'Bigtop'
  1. Bigtop
  2. BIGTOP-1022

Giraph build script should also specify ZooKeeper, HBase, and Hive versions

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.7.0
    • Fix Version/s: 1.1.0
    • Component/s: None
    • Labels:
      None

      Description

      The Giraph build script does not specify BOM versions of ZooKeeper, HBase, or Hive. Giraph itself doesn't support build time override of ZooKeeper version but that has been proposed as GIRAPH-710. If we can override the ZooKeeper version at build time, GIRAPH-712 is required to compile against the current ZooKeeper in the BOM (3.4.5).

      1. 1022.patch
        1 kB
        Andrew Purtell

        Issue Links

          Activity

          Hide
          cos Konstantin Boudnik added a comment -

          Is it still an issue? If so - please validate the patch and update the ticket to "Patch Avail"

          Show
          cos Konstantin Boudnik added a comment - Is it still an issue? If so - please validate the patch and update the ticket to "Patch Avail"
          Hide
          rvs Roman Shaposhnik added a comment -

          Andrew Purtell Andrew – totally up to you!

          Show
          rvs Roman Shaposhnik added a comment - Andrew Purtell Andrew – totally up to you!
          Hide
          apurtell Andrew Purtell added a comment -

          GIRAPH-710 was accepted but there's not release including it yet. There has been no action on GIRAPH-712, I'm watching dev@giraph. When they have the next release discussion I will chime in. Until then the changes here are no-ops. I can still commit if you like Roman Shaposhnik

          Show
          apurtell Andrew Purtell added a comment - GIRAPH-710 was accepted but there's not release including it yet. There has been no action on GIRAPH-712 , I'm watching dev@giraph. When they have the next release discussion I will chime in. Until then the changes here are no-ops. I can still commit if you like Roman Shaposhnik
          Hide
          rvs Roman Shaposhnik added a comment -

          +1

          Andrew, could you please commit this?

          Show
          rvs Roman Shaposhnik added a comment - +1 Andrew, could you please commit this?
          Hide
          apurtell Andrew Purtell added a comment -

          Also, in Giraph 1.0, the 'hadoop_yarn' profile does not enable the giraph-hbase module, so setting the HBase version in the build script has no effect at this time, but, IMHO, should still be done for future proofing.

          Show
          apurtell Andrew Purtell added a comment - Also, in Giraph 1.0, the 'hadoop_yarn' profile does not enable the giraph-hbase module, so setting the HBase version in the build script has no effect at this time, but, IMHO, should still be done for future proofing.
          Hide
          apurtell Andrew Purtell added a comment -

          If Giraph elects not to take up either GIRAPH-712 or GIRAPH-710 or both, then the attached patch can simply be amended not to include the define of 'zookeeper.version'.

          Show
          apurtell Andrew Purtell added a comment - If Giraph elects not to take up either GIRAPH-712 or GIRAPH-710 or both, then the attached patch can simply be amended not to include the define of 'zookeeper.version'.

            People

            • Assignee:
              andrew.purtell@gmail.com Andrew Purtell
              Reporter:
              apurtell Andrew Purtell
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development