Details

    • Improvement
    • Status: Resolved
    • P3
    • Resolution: Fixed
    • None
    • 2.37.0
    • dependencies, sdk-java-core
    • None

    Description

      This upgrade brings the latest improvements of zstd and fixes breaking Beam Java SDK Core tests related errors on Mac M1

      java.lang.UnsatisfiedLinkError: no zstd-jni in java.library.path
      Unsupported OS/arch, cannot find /darwin/aarch64/libzstd-jni.dylib or load zstd-jni from system libraries. Please try building from source the jar or providing libzstd-jni in your system.±

       

      Attachments

        Issue Links

          Activity

            People

              iemejia Ismaël Mejía
              iemejia Ismaël Mejía
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 4h 10m
                  4h 10m

                  Slack

                    Issue deployment