Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-12906

Track DataFrame pandas requirement separately

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • P2
    • Resolution: Fixed
    • None
    • 2.34.0
    • dsl-dataframe
    • None

    Description

      Currently we rely on the "test" extra to track supported pandas versions. We should instead have a "dataframe" extra which tracks the pandas requirement for the DataFrame API.

      When we add this extra we should also make sure to update any documentation that discusses the pandas requirement (e.g. https://github.com/apache/beam/pull/15470#discussion_r710404187)

      Attachments

        Issue Links

          Activity

            People

              bhulette Brian Hulette
              bhulette Brian Hulette
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 6h
                  6h