Uploaded image for project: 'Beam'
  1. Beam
  2. BEAM-10227

python_version qualifiers are ignored for typing dependency.

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • P2
    • Resolution: Fixed
    • None
    • 2.23.0
    • sdk-py-core
    • None

    Description

       
      :~$ docker -- run -it --entrypoint=/bin/bash  gcr.io/cloud-dataflow/v1beta3/python3:2.22.0
      root@bcd3693fbfa1:/# python --version
      Python 3.5.9
      
      root@bcd3693fbfa1:/#  pip install 'typing; python_version < "3.5"'
      Ignoring typing: markers 'python_version < "3.5"' don't match your environment
      
      root@bcd3693fbfa1:/#  pip install 'typing; python_version < "3.5.3"'
      Collecting typing
        Downloading typing-3.7.4.1-py3-none-any.whl (25 kB)
      Installing collected packages: typing
      Successfully installed typing-3.7.4.1
      

      The second download should not be happening according to the expressed intent, but it does. using python_full_version fixes that. See also: https://www.python.org/dev/peps/pep-0508/.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            tvalentyn Valentyn Tymofieiev
            tvalentyn Valentyn Tymofieiev
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 0.5h
                0.5h

                Issue deployment