Uploaded image for project: 'Axis2'
  1. Axis2
  2. AXIS2-5993

Upgrade logging to log4j v2.x

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.9
    • Fix Version/s: 1.8.0
    • Component/s: client-api
    • Labels:
      None
    • Environment:
      Tomcat

      Description

      https://nvd.nist.gov/vuln/detail/CVE-2019-17571

      This vulnerability prompts us to upgrade to a v2 version of log4j since all v1 versions are end of support. However all versions of axis2 still use v1 log4j.

      If axis2 is not updated, then we will need to move to another web service container.

       

        Attachments

          Activity

            People

            • Assignee:
              robertlazarski Robert Lazarski
              Reporter:
              gknott Gregory Knott

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment