Uploaded image for project: 'Axis2'
  1. Axis2
  2. AXIS2-5886

Axis2 - Authentication state already initialized

    XMLWordPrintableJSON

    Details

      Description

      Hi,

      I'm trying to call a webservice, out of my network, using proxy. The service is reacheable from browser but not using the client.
      My proxy settings are written in this way:

      HttpTransportProperties.ProxyProperties proxyProperties = new HttpTransportProperties.ProxyProperties();
      proxyProperties.setProxyName(proxyname);
      proxyProperties.setProxyPort(proxyport);
      proxyProperties.setDomain(domain);
      proxyProperties.setPassWord(password);
      proxyProperties.setUserName(username);
      service._getServiceClient().getOptions().setProperty(org.apache.axis2.transport.http.HTTPConstants.PROXY, proxyProperties);

      With this settings the program raises this error:

      Exception in thread "main" java.lang.IllegalStateException: Authentication state already initialized
      at org.apache.commons.httpclient.auth.AuthState.setPreemptive(AuthState.java:120)
      at org.apache.commons.httpclient.HttpMethodDirector.executeConnect(HttpMethodDirector.java:487)
      at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:391)
      at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
      at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
      at org.apache.axis2.transport.http.impl.httpclient3.HTTPSenderImpl.executeMethod(HTTPSenderImpl.java:872)
      at org.apache.axis2.transport.http.impl.httpclient3.HTTPSenderImpl.sendViaPost(HTTPSenderImpl.java:212)
      at org.apache.axis2.transport.http.HTTPSender.send(HTTPSender.java:121)
      at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(CommonsHTTPTransportSender.java:403)
      at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(CommonsHTTPTransportSender.java:234)
      at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:431)
      at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:399)
      at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:225)
      at org.apache.axis2.client.OperationClient.execute(OperationClient.java:150)
      at com.microsoft.schemas.crm._2006.webservices.CustomerIntegrationServiceStub.findCustomer(CustomerIntegrationServiceStub.java:741)
      at com.cdb.Service.main(Service.java:48)

      If I not use this settings I receive a timeout connection, if I not pass the credentials I receive an error about authentication required.

      I searched on the web and on your issues and the problem seemed solved with the http-client version 4, but I used always this version so I would need an help.

      Thanks

        Attachments

        1. screenshot-1.png
          151 kB
          Andrea Porporino

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              suxper Andrea Porporino
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: