Axis2
  1. Axis2
  2. AXIS2-3636

Axis2-1.4-RC1: Advanced-rmi sample client fails

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: None
    • Component/s: samples
    • Labels:
      None
    • Environment:
      winxp, jdk15

      Description

      Advanced-rmi sample client fails with the following exceptions.

      ============================================================================================
      C:\Axis2\axis2-1.4\axis2-637511\samples\advanced-rmi>ant run_client
      Buildfile: build.xml

      init:

      clean:
      [delete] Deleting directory C:\Axis2\axis2-1.4\axis2-637511\samples\advanced-rmi\classes
      [delete] Deleting directory C:\Axis2\axis2-1.4\axis2-637511\dist

      run_client:
      [echo] Running the RMI clients
      [mkdir] Created dir: C:\Axis2\axis2-1.4\axis2-637511\samples\advanced-rmi\classes
      [mkdir] Created dir: C:\Axis2\axis2-1.4\axis2-637511\dist
      [javac] Compiling 15 source files to C:\Axis2\axis2-1.4\axis2-637511\samples\advanced-rmi\classes
      [javac] Note: C:\Axis2\axis2-1.4\axis2-637511\samples\advanced-rmi\src\sample\rmi\server\dto\TestComplexBean.java uses unchecked or unsafe operations.
      [javac] Note: Recompile with -Xlint:unchecked for details.
      [jar] Building jar: C:\Axis2\axis2-1.4\axis2-637511\dist\rmi_client.jar
      [java] 2008-03-19 21:01:00,687 INFO org.apache.axis2.deployment.ModuleDeployer - Deploying module: metadataExchange-637511 - file:/C:/Axis2/axis2-1.4/axis2-637511/lib/mex-637511.jar
      [java] java.lang.reflect.UndeclaredThrowableException
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:194)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:747)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:201)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:104)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [java] at org.apache.tools.ant.Task.perform(Task.java:348)
      [java] at org.apache.tools.ant.Target.execute(Target.java:357)
      [java] at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [java] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [java] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [java] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [java] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [java] at org.apache.tools.ant.Main.runBuild(Main.java:698)
      [java] at org.apache.tools.ant.Main.startAnt(Main.java:199)
      [java] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      [java] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      [java] Caused by: java.lang.reflect.UndeclaredThrowableException
      [java] at $Proxy0.method1(Unknown Source)
      [java] at sample.rmi.client.TestService1.testMethod1(TestService1.java:68)
      [java] at sample.rmi.client.TestService1.main(TestService1.java:124)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.run(ExecuteJava.java:217)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:152)
      [java] ... 20 more
      [java] Caused by: org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) 127.0.0.1/axis2/services/Service1
      [java] at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:481)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:370)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:416)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:228)
      [java] at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:548)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:528)
      [java] at org.apache.axis2.rmi.client.RMIClient.invokeMethod(RMIClient.java:119)
      [java] at org.apache.axis2.rmi.client.ProxyInvocationHandler.invoke(ProxyInvocationHandler.java:41)
      [java] ... 29 more
      [java] — Nested Exception —
      [java] java.lang.reflect.UndeclaredThrowableException
      [java] at $Proxy0.method1(Unknown Source)
      [java] at sample.rmi.client.TestService1.testMethod1(TestService1.java:68)
      [java] at sample.rmi.client.TestService1.main(TestService1.java:124)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.run(ExecuteJava.java:217)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:152)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:747)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:201)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:104)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [java] at org.apache.tools.ant.Task.perform(Task.java:348)
      [java] at org.apache.tools.ant.Target.execute(Target.java:357)
      [java] at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [java] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [java] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [java] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [java] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [java] at org.apache.tools.ant.Main.runBuild(Main.java:698)
      [java] at org.apache.tools.ant.Main.startAnt(Main.java:199)
      [java] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      [java] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      [java] Caused by: org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) 127.0.0.1/axis2/services/Service1
      [java] at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:481)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:370)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:416)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:228)
      [java] at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:548)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:528)
      [java] at org.apache.axis2.rmi.client.RMIClient.invokeMethod(RMIClient.java:119)
      [java] at org.apache.axis2.rmi.client.ProxyInvocationHandler.invoke(ProxyInvocationHandler.java:41)
      [java] ... 29 more
      [java] 2008-03-19 21:01:02,890 INFO org.apache.axis2.deployment.ModuleDeployer - Deploying module: metadataExchange-637511 - file:/C:/Axis2/axis2-1.4/axis2-637511/lib/mex-637511.jar
      [java] java.lang.reflect.UndeclaredThrowableException
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:194)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:747)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:201)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:104)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [java] at org.apache.tools.ant.Task.perform(Task.java:348)
      [java] at org.apache.tools.ant.Target.execute(Target.java:357)
      [java] at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [java] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [java] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [java] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [java] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [java] at org.apache.tools.ant.Main.runBuild(Main.java:698)
      [java] at org.apache.tools.ant.Main.startAnt(Main.java:199)
      [java] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      [java] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      [java] Caused by: java.lang.reflect.UndeclaredThrowableException
      [java] at $Proxy1.method1(Unknown Source)
      [java] at sample.rmi.client.TestService2.testMethod1(TestService2.java:50)
      [java] at sample.rmi.client.TestService2.main(TestService2.java:86)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.run(ExecuteJava.java:217)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:152)
      [java] ... 20 more
      [java] Caused by: org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) 127.0.0.1/axis2/services/Service2
      [java] at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:481)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:370)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:416)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:228)
      [java] at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:548)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:528)
      [java] at org.apache.axis2.rmi.client.RMIClient.invokeMethod(RMIClient.java:119)
      [java] at org.apache.axis2.rmi.client.ProxyInvocationHandler.invoke(ProxyInvocationHandler.java:41)
      [java] ... 29 more
      [java] — Nested Exception —
      [java] java.lang.reflect.UndeclaredThrowableException
      [java] at $Proxy1.method1(Unknown Source)
      [java] at sample.rmi.client.TestService2.testMethod1(TestService2.java:50)
      [java] at sample.rmi.client.TestService2.main(TestService2.java:86)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.run(ExecuteJava.java:217)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:152)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:747)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:201)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:104)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [java] at org.apache.tools.ant.Task.perform(Task.java:348)
      [java] at org.apache.tools.ant.Target.execute(Target.java:357)
      [java] at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [java] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [java] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [java] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [java] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [java] at org.apache.tools.ant.Main.runBuild(Main.java:698)
      [java] at org.apache.tools.ant.Main.startAnt(Main.java:199)
      [java] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      [java] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      [java] Caused by: org.apache.axis2.AxisFault: The service cannot be found for the endpoint reference (EPR) 127.0.0.1/axis2/services/Service2
      [java] at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:481)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.handleResponse(OutInAxisOperation.java:370)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:416)
      [java] at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:228)
      [java] at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:548)
      [java] at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:528)
      [java] at org.apache.axis2.rmi.client.RMIClient.invokeMethod(RMIClient.java:119)
      [java] at org.apache.axis2.rmi.client.ProxyInvocationHandler.invoke(ProxyInvocationHandler.java:41)
      [java] ... 29 more
      [java] Could not find sample.rmi.client.TestService3. Make sure you have it in your classpath
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:138)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:747)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:201)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:104)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [java] at org.apache.tools.ant.Task.perform(Task.java:348)
      [java] at org.apache.tools.ant.Target.execute(Target.java:357)
      [java] at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [java] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [java] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [java] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [java] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [java] at org.apache.tools.ant.Main.runBuild(Main.java:698)
      [java] at org.apache.tools.ant.Main.startAnt(Main.java:199)
      [java] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      [java] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
      [java] Could not find sample.rmi.client.TestService4. Make sure you have it in your classpath
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:138)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:747)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:201)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:104)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [java] at org.apache.tools.ant.Task.perform(Task.java:348)
      [java] at org.apache.tools.ant.Target.execute(Target.java:357)
      [java] at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [java] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [java] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [java] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [java] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [java] at org.apache.tools.ant.Main.runBuild(Main.java:698)
      [java] at org.apache.tools.ant.Main.startAnt(Main.java:199)
      [java] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
      [java] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

        Activity

        Davanum Srinivas made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Davanum Srinivas added a comment -

        removed rmi from all the dists in svn revision 640695. (you will need to add an entry in the root pom.xml, if you want to build it from svn). Because if i leave it there, the source dist will not build.

        – dims

        Davanum Srinivas made changes -
        Assignee Amila Chinthaka Suriarachchi [ amilachinthaka ] Davanum Srinivas [ dims ]
        Amila Chinthaka Suriarachchi added a comment -

        hi dims,
        Could you please remove the rmi from the distribution?

        thanks,
        Amila.

        Davanum Srinivas made changes -
        Field Original Value New Value
        Assignee Amila Chinthaka Suriarachchi [ amilachinthaka ]
        Charitha Kankanamge created issue -

          People

          • Assignee:
            Davanum Srinivas
            Reporter:
            Charitha Kankanamge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development