Uploaded image for project: 'Axis'
  1. Axis
  2. AXIS-2871

javax.xml.soap.SOAPException: java.lang.OutOfMemoryError : During Deserialization of SOAP Axis 1.4

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Incomplete
    • Affects Version/s: 1.4
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Aix 6, jdk 1.5, WAS 7.0, Axis 1.4

      Description

      Axis throws out of memory error during Deserialization. Is there any fix or patch available to remidiate this issue or error....

      Deserializati E org.apache.axis.encoding.DeserializationContext pushNewElement Exception:
      javax.xml.soap.SOAPException: java.lang.OutOfMemoryError

      at org.apache.axis.message.NodeImpl.setParentElement(NodeImpl.java:634)
      at org.apache.axis.encoding.DeserializationContext.pushNewElement(DeserializationContext.java:774)
      at org.apache.axis.message.SOAPHandler.startElement(SOAPHandler.java:94)
      at org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1048)
      at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
      at org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source)
      at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
      at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
      at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
      at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
      at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
      at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
      at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
      at org.apache.axis.encoding.DeserializationContext.parse(DeserializationContext.java:227)
      at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:696)
      at org.apache.axis.Message.getSOAPEnvelope(Message.java:435)
      at org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecker.java:62)
      at org.apache.axis.client.AxisClient.invoke(AxisClient.java:206)
      at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
      at org.apache.axis.client.Call.invoke(Call.java:2767)
      at org.apache.axis.client.Call.invoke(Call.java:2443)
      at org.apache.axis.client.Call.invoke(Call.java:2366)
      at org.apache.axis.client.Call.invoke(Call.java:1812)

        Issue Links

          Activity

          veithen Andreas Veithen added a comment -

          Closing this issue as incomplete because the reporter didn't provide any evidence that this is a problem in Axis. It is not enough to "suspect" that the problem is "related to Axis". As explained earlier, a heap dump is required to investigate such issues.

          pyada10 Pankaj Yadav added a comment -

          Hi Andreas,
          Do we have any update on this Bug.

          gaurav1205 Gaurav added a comment -

          It is a recurring situation for us, we keep getting this situation two to three times in a day. I have confirmed with infra team that there is no memory leak in the application and the failure happens at the same place everytime and have enough heap memory. When deserializing the webservice response, so we suspect it related to Axis.

          veithen Andreas Veithen added a comment -

          I assume that the JVM has enough heap and that the issue only occurs after some time, i.e. that there is a memory leak. Can you confirm that?

          Do you have a heap dump that provides evidence that the leak is indeed caused by Axis?


            People

            • Assignee:
              Unassigned
              Reporter:
              gaurav1205 Gaurav
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development