Axiom
  1. Axiom
  2. AXIOM-319

Clarify the status of the JavaMail dependency

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.9
    • Component/s: None
    • Labels:
      None

      Description

      axiom-api depends on Geronimo's JavaMail implementation. On the other hand, in axiom-tests this dependency is excluded and replaced by Sun's JavaMail dependency (same situation in Axis2).

      If Axiom doesn't work properly with Geronimo's JavaMail implementation, we should either make sure that the bugs in Geronimo get fixed or change the dependencies of axiom-api. If Axiom works properly with Geronimo's JavaMail implementation, then it doesn't make sense to run the tests against a different JavaMail implementation.

        Issue Links

          Activity

          Thilina Gunarathne added a comment -

          AFAIK Axis2 ships sun mail & activation implementations. A quick look at Axis2 1.4.1 confirmed this.

          We got rid of the gerenimo-impl's when Sun changed mail & activation to a favorable license terms. I do not know about the current situation, but back then Gerenimo impl's were not complete. IIRC it was mostly the activation, where they did not support some content-type bindings.

          +1 for switching completely to Sun mail+activation...

          Jarek Gawor added a comment -

          (As a Geronimo person) I think it would be good to use Geronimo jars over Sun. The Geronimo JavaMail implementation is much better now and we are pretty good about fixing bugs in it.

          Andreas Veithen added a comment -

          Jarek,

          I still have two open issues with Geronimo JavaMail: GERONIMO-4352 and GERONIMO-4421. The first one causes failures in the mail transport (if we move to Geronimo, we should make sure that the mail transport works reasonably well with it) and the second will potentially cause an issue for Axiom itself. Maybe you can push a bit so that they get solved?

          Asankha C. Perera added a comment -

          I think the problem occurred since earlier versions of Sun Javamail or Activation were not available on M2 repos probably due to some licensing issues.

          Now Axis2 poms have a dependency on both Geronimo and Sun Javamail, which creates problems [1], and confusion

          I would like the Axis2 mail transport to depend on Sun Javamail v1.4.2 (which is the latest as of now and available on M2 Repos), and exclude the use of geronimo JARs altogether for the Commons Transports 1.0 release

          [1] http://forums.sun.com/thread.jspa?messageID=10657165

          Andreas Veithen added a comment -

          On a similar question in the context of CXF, Daniel Kulp gave some additional arguments in support of the Geronimo implementations. See [1].

          [1] http://markmail.org/message/xanxtu2s4ukjhn3k

          Andreas Veithen added a comment -

          Axiom (including the tests) now works correctly with the Geronimo JARs. Therefore I'm going to close this issue. Note that Axis2 still overrides the dependency to use Sun's implementations.


            People

            • Assignee:
              Unassigned
              Reporter:
              Andreas Veithen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development