Axiom
  1. Axiom
  2. AXIOM-24

OMDocument#serializeAndConsume doesn't consume the document

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.8
    • Fix Version/s: 1.2.11
    • Component/s: DOOM, LLOM
    • Labels:
      None

      Description

      OMDocument#serializeAndConsume doesn't consume the document but instead fully builds it.

      This is caused by the following piece of code:

      while (children.hasNext())

      { OMNodeEx omNode = (OMNodeEx) children.next(); omNode.internalSerializeAndConsume(writer); }

      As described in WSCOMMONS-346, the call to Iterator#next() actually builds the returned node, so that the call to internalSerializeAndConsume has the same effect as serialization with caching enabled. This means that the code fully builds the document.

      Note that the code actually doesn't make sense because once a child (in particular the document element) has been consumed, it is not possible to retrieve the next sibling. This means that even if WSCOMMONS-346 is solved, the code still wouldn't behave as expected. Worse, it would trigger an exception.

        Issue Links

          Activity

          Andreas Veithen added a comment -

          There are two possible solutions for this issue: WSCOMMONS-450 and WSCOMMONS-451.

          Andreas Veithen added a comment -

          Postponing this issue to 1.2.10 since WSCOMMONS-450 is scheduled for 1.2.10 and WSCOMMONS-451 for 1.3.

          Hudson added a comment -

          Integrated in ws-axiom-trunk #300 (See https://hudson.apache.org/hudson/job/ws-axiom-trunk/300/)
          Added two new test cases for OMContainer#serializeAndConsume. They will be necessary to ensure non regression when implementing AXIOM-24. In addition, they reveal problems in DOOM which may be related to AXIOM-315.

          Hudson added a comment -

          Integrated in ws-axiom-trunk #312 (See https://hudson.apache.org/hudson/job/ws-axiom-trunk/312/)


            People

            • Assignee:
              Andreas Veithen
              Reporter:
              Andreas Veithen
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development