Uploaded image for project: 'Apache Avro'
  1. Apache Avro
  2. AVRO-2807

Pin RuboCop to <=0.81

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.10.0
    • Component/s: build, docker
    • Labels:
      None

      Description

      RuboCop 0.82 has been released, which drops Ruby 2.3 support.
      https://github.com/rubocop-hq/rubocop/releases/tag/v0.82.0

      We are still using Ruby 2.3 in the Docker image, so creating container fails as follows. It have to be pinned to 0.81, just like AVRO-2664.

      $ ./build.sh docker
      
      (snip)
      
      Step 16/27 : RUN bundle install --gemfile=/tmp/Gemfile
       ---> Running in 79407933cb02
      Don't run Bundler as root. Bundler can ask for sudo if it is needed, and
      installing your bundle as root will break this application for all non-root
      users on this machine.
      Fetching gem metadata from https://rubygems.org/.................
      Fetching version metadata from https://rubygems.org/.
      Resolving dependencies...
      rubocop-0.82.0 requires ruby version >= 2.4.0, which is incompatible with the
      current version, ruby 2.3.3p222
      The command '/bin/sh -c bundle install --gemfile=/tmp/Gemfile' returned a non-zero code: 5
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sekikn Kengo Seki
                Reporter:
                sekikn Kengo Seki
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: