Uploaded image for project: 'Apache Avro'
  1. Apache Avro
  2. AVRO-2020

Update BUILD instructions with correct versions for language-specific libraries

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.7.7, 1.8.1, 1.9.0
    • Fix Version/s: 1.9.0
    • Component/s: community, doc
    • Labels:
      None

      Description

      our BUILD instructions current list a few things I know are wrong (Ruby 1.8 support) and some things I'm pretty sure are wrong (Java 1.6 support).

      we should do a pass checking all the languages.

      REQUIREMENTS
      
      The following packages must be installed before Avro can be built:
      
       - Java: JDK 1.6, Maven 2 or better, protobuf-compile
       - PHP: php5, phpunit, php5-gmp
       - Python: 2.5 or greater, python-setuptools for dist target
       - C: gcc, cmake, asciidoc, source-highlight
       - C++: cmake 2.8.4 or greater, g++, flex, bison, libboost-dev
       - C#: mono-devel mono-gmcs nunit
       - JavaScript: nodejs, npm
       - Ruby: ruby 1.86 or greater, ruby-dev, gem, rake, echoe, yajl-ruby
       - Perl: perl 5.8.1 or greater, gmake, Module::Install,
         Module::Install::ReadmeFromPod, Module::Install::Repository,
         Math::BigInt, JSON::XS, Try::Tiny, Regexp::Common, Encode,
         IO::String, Object::Tiny, Compress::ZLib, Test::More,
         Test::Exception, Test::Pod
       - Apache Ant 1.7
       - Apache Forrest 0.8 (for documentation)
       - md5sum, sha1sum, used by top-level dist target
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              busbey Sean Busbey
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: