There's a method of SpecificRecordBase.java which has a typo in the method name, i.e., `getConverion(String fieldName)` instead of `getConversion(String fieldName)`.
gszadovszky suggests two options, detailed below:
This method is part of the public API and has already been released (1.8.1). We would not like to break the code of any consumer in case of doing a minor upgrade therefore, I would suggest deprecating the method with the typo and create a new one with the correct naming. (Later on we will be able to remove the deprecated method.) Another idea is to keep the fix as is but only include in the next major release.