Uploaded image for project: 'Aurora'
  1. Aurora
  2. AURORA-930

GC performance issues with snapshot deduplication on large clusters

    Details

    • Type: Story
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.7.0
    • Component/s: Scheduler
    • Labels:
      None
    • Sprint:
      Twitter Aurora Q4 Sprint 4, Twitter Aurora Q4 Sprint 5

      Description

      We observed very long GC pauses in our production cluster we believe are caused by the extra heap pressure caused by SnapshotDeduplicatorImpl's extra deep copy of a Snapshot object.

      Also, EntrySerializer fully buffers the full binary-encoded thrift Snapshot before writing it to the replicated log - it can avoid memory pressure by streaming instead.

        Issue Links

          Activity

          kevints Kevin Sweeney added a comment -
          kevints Kevin Sweeney added a comment -

          Still investigating but it looks like the current implementation of SnapshotDeduplicator generates a lot of garbage when used in clusters that are very large.

          wfarner Bill Farner added a comment -

          Ticket is ill-defined, please add details or close.


            People

            • Assignee:
              kevints Kevin Sweeney
              Reporter:
              clambert Chris Lambert
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Agile