Uploaded image for project: 'Atlas'
  1. Atlas
  2. ATLAS-1707

Atlas WUI on continues loading behind FireWall

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 0.7-incubating
    • 0.8.1, 1.0.0
    • atlas-webui
    • Atlas: Version":"0.7.0.2.5.3
      JDK 1.8
      Linux
    • Hide
      1. Set FW to not return any type of response.
      2. Try to login into Atlas page.
      Show
      1. Set FW to not return any type of response. 2. Try to login into Atlas page.

    Description

      Atlas is behind a FW in which does return a response. We Identify index.html was loading googleapis css does not have a timeout and proceed with the WUI;

      ref:http://tinyurl.com/lan4by9
      By removing the bellow line from the html file, there were no problem.

      <link href="https://fonts.googleapis.com/css?family=Source+Sans+Pro:400,400italic,600,600italic,700,700italic" rel="stylesheet" type="text/css">

      1. Shouldn't be applications self-contain in case of such situation?

      Attachments

        1. ATLAS-1707.2.patch
          6 kB
          Ashutosh Mestry
        2. ATLAS-1707.3.patch
          18 kB
          Nixon Rodrigues
        3. ATLAS-1707.patch
          58 kB
          Nixon Rodrigues
        4. index.html
          3 kB
          Ernani Pereira de Mattos Junior
        5. index.html.original
          4 kB
          Ernani Pereira de Mattos Junior

        Issue Links

          Activity

            People

              nixon Nixon Rodrigues
              emattosHWX Ernani Pereira de Mattos Junior
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: