Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-6052

[C++] Divide up arrow/array.h,cc into files in arrow/array/ similar to builder files

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 1.0.0
    • C++

    Description

      Since these files are getting larger, this would improve codebase navigability. Probably should use the same naming scheme as builder_* e.g. arrow/array/array_dict.h

      I recommend also putting the unit test files related to these in there for better semantic organization.

      Attachments

        Issue Links

          Activity

            People

              wesm Wes McKinney
              wesm Wes McKinney
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 1.5h
                  1.5h