There are semantic differences between enable_ifs-related utils and is_xxx functions with the same name. For example, is_binary_like here != here. The former includes binary only and the latter binary/string types.
Also, the _like suffix seems unwarranted as they always refer to binary or string.
Also, the is_fixed_size_binary includes both FixedSizeBinaryType and DecimalXXXType. A better name is is_base_fixed_size_binary to match how binary/string utils are used.
Note: There might be other inconsistencies.