Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-11510

[Python] Add note that pip >= 19.0 is required to get binary packages

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Resolved
    • Minor
    • Resolution: Fixed
    • 3.0.0
    • 4.0.0
    • Python

    Description

      Since ARROW-5756 dropped support for manylinux1 the required pip version is now 19.  Ubuntu 18 and some other older Linux distros still ship with an older pip version.  Currently they don't get any clear error, pip falls back to building from source and that usually fails.  This warning will hopefully help alleviate this.

      Attachments

        Issue Links

          Activity

            People

              westonpace Weston Pace
              westonpace Weston Pace
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 1h 10m
                  1h 10m