Uploaded image for project: 'Apache Arrow'
  1. Apache Arrow
  2. ARROW-1124

[Python] pyarrow needs to depend on numpy>=1.10 (not 1.9)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 0.4.1
    • Fix Version/s: 0.5.0
    • Component/s: Python
    • Labels:
      None

      Description

      The pyarrow package lists numpy >= 1.9 as a dependency in setup.py - however, it causes an exception at import time with numpy 1.9.

      Repro steps:

      {{$ pip install numpy==1.9
      ...
      $ pip install pyarrow
      ...
      $ python -c 'import pyarrow'
      RuntimeError: module compiled against API version a but this version of numpy is 9
      Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/home/dima/envs/pyarrow-bug/lib/python2.7/site-packages/pyarrow/_init_.py", line 28, in <module>
      from pyarrow.lib import cpu_count, set_cpu_count
      File "pyarrow/lib.pyx", line 40, in init pyarrow.lib (/arrow/python/build/temp.linux-x86_64-2.7/lib.cxx:62119)
      ImportError: numpy.core.multiarray failed to import
      }}

      (Additionally, requirements.txt lists "numpy>=1.7" - though it doesn't look like it's used at all.)

        Attachments

          Activity

            People

            • Assignee:
              xhochy Uwe L. Korn
              Reporter:
              dimaryaz Dima Ryazanov
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: