Uploaded image for project: 'Maven Archetype'
  1. Maven Archetype
  2. ARCHETYPE-519

archetype:generate with specified remote archetypeCatalog falls back to internal catalog

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.1
    • Component/s: Generator
    • Labels:
      None
    • Environment:
      Mac OS X 10.11.6, Apache Maven 3.2.3

      Description

      We were surprised to find out that our archetype was "suddenly" not working anymore. It turns out it was the release of org.apache.maven.plugins:maven-archetype-plugin:3.0.0 from 12/Feb/17 that was the culprit.

      When running:
      mvn org.apache.maven.plugins:maven-archetype-plugin:3.0.0:generate -DarchetypeCatalog=<remote-catalog-url-from-our-nexus> we end up with the plugin falling back to the internal catalog:

      [INFO] Scanning for projects...
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Maven Stub Project (No POM) 1
      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] >>> maven-archetype-plugin:3.0.0:generate (default-cli) > generate-sources @ standalone-pom >>>
      [INFO]
      [INFO] <<< maven-archetype-plugin:3.0.0:generate (default-cli) < generate-sources @ standalone-pom <<<
      [INFO]
      [INFO] --- maven-archetype-plugin:3.0.0:generate (default-cli) @ standalone-pom ---
      [INFO] Generating project in Interactive mode
      [INFO] No catalog defined. Using internal catalog
      [INFO] No archetype defined. Using maven-archetype-quickstart (org.apache.maven.archetypes:maven-archetype-quickstart:1.0)
      Choose archetype:
      1: internal -> org.apache.maven.archetypes:maven-archetype-archetype (An archetype which contains a sample archetype.)
      2: internal -> org.apache.maven.archetypes:maven-archetype-j2ee-simple (An archetype which contains a simplifed sample J2EE application.)
      3: internal -> org.apache.maven.archetypes:maven-archetype-plugin (An archetype which contains a sample Maven plugin.)
      4: internal -> org.apache.maven.archetypes:maven-archetype-plugin-site (An archetype which contains a sample Maven plugin site.
            This archetype can be layered upon an existing Maven plugin project.)
      5: internal -> org.apache.maven.archetypes:maven-archetype-portlet (An archetype which contains a sample JSR-268 Portlet.)
      6: internal -> org.apache.maven.archetypes:maven-archetype-profiles ()
      7: internal -> org.apache.maven.archetypes:maven-archetype-quickstart (An archetype which contains a sample Maven project.)
      8: internal -> org.apache.maven.archetypes:maven-archetype-site (An archetype which contains a sample Maven site which demonstrates
            some of the supported document types like APT, XDoc, and FML and demonstrates how
            to i18n your site. This archetype can be layered upon an existing Maven project.)
      9: internal -> org.apache.maven.archetypes:maven-archetype-site-simple (An archetype which contains a sample Maven site.)
      10: internal -> org.apache.maven.archetypes:maven-archetype-webapp (An archetype which contains a sample Maven Webapp project.)
      Choose a number or apply filter (format: [groupId:]artifactId, case sensitive contains):
      

      Version 2.4 works as expected (the archetype catalog exists under given URL and can be downloaded).

        Issue Links

          Activity

          shyrkov Sergiy Shyrkov added a comment -

          Hello,

          we experience the same issue with the version 3.0.0 of the plugin now (no issue with version 2.3 and 2.4). And as our platform is using archetype:generate with archetypeCatalog and other options in a non-interactive (batch mode), our generate action always fail now.

          Would it be possible to raise the priority of this issue as it is a regression and quite blocking for us, unfortunately

          Thank you in advance!

          Kind regards
          Sergiy

          rfscholte Robert Scholte added a comment -

          http://maven.apache.org/archetype/maven-archetype-plugin/generate-mojo.html#archetypeCatalog shows that it is not possible anymore to refer directly to a catalog by URL or File. Instead you can add a repository to your settings.xml with id archetype. That should make it work again.

          ilgrosso Francesco Chicchiriccò added a comment -

          Any chance to revert somehow to the old behavior working until 2.4? At the moment we are using the old version as workaround...

          rfscholte Robert Scholte added a comment -

          If by reverting you mean: allowing references via http or file, then the answer is no. In fact, I thought of removing the archetypeCatalog parameter completely because it looks like it has become useless (or so it should), but I couldn't decide. The whole idea is to have less commandline options and to make use of standard functionality provided by Maven3, aka more out of the box.

          rfscholte Robert Scholte added a comment -

          I've just verified that -DarchetypeCatalog=<remote-catalog-url-from-our-nexus> will indeed fall back to internal catalog as expected, because none of the catalogs could be resolved. Removing -DarchetypeCatalog will go to central or its mirror.
          To prevent confusion I've decided to throw an IllegalArgumentException in case of unknown archetypeCatalog values.
          Fixed in 9e828c30482d0ed38b84f35e86d0eca166f094f6

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-archetype-m3 #263 (See https://builds.apache.org/job/maven-archetype-m3/263/)
          ARCHETYPE-519 archetype:generate with specified remote (rfscholte: rev 9e828c30482d0ed38b84f35e86d0eca166f094f6)

          • (edit) maven-archetype-plugin/src/main/java/org/apache/maven/archetype/ui/generation/DefaultArchetypeSelector.java
          • (delete) maven-archetype-plugin/src/it/generate-basic/setup.groovy
          • (edit) maven-archetype-plugin/src/main/java/org/apache/maven/archetype/mojos/CreateProjectFromArchetypeMojo.java
          ilgrosso Francesco Chicchiriccò added a comment -

          I understand the rationale behind this change; in my case we are providing instructions to users that want to try the SNAPSHOT versions of Apache Syncope: I will change the instructions to add a repository in ~/.m2/settings.xml with a certain id and then run archetype:generate with -DarchetypeCatalog with that it.

          Thanks for explanations.

          sbordet Simone Bordet added a comment -

          I frankly don't understand the rationale behind this - is there any detailed discussion/reference about ?

          I loved the idea that newcomers to a project could just run mvn archetype:generate -DarchetypeCatalog=http://project.org from any directory and voilà they had a project ready.

          Now they have to fiddle with the settings.xml file, which they may not have, which in Windows who knows where it actually is, lookup what to paste, be sure there are no XML errors, etc.

          In the instructions to quickly try out a project, the difference is between 1 line of documentation and 1 page of documentation - the latter tends to drive people away.

          I would appreciate to have the rationale explained.

          Thanks !

          hsaputra Henry Saputra added a comment -

          I dont this is really thought through.

          In some cases, it is cumbersome to make user to change his/her settings.xml or they dont even know they have settings.xml file.

          Could we have the original behavior or at least config to turn it back on as optional param?

          adouma Ate Douma added a comment -

          I agree, this is a really problematic change.
          It is causing problems for new users getting started with our Hippo CMS product, for which we don't have the archetype on Maven Central, and neither intend to move it there.

          As a workaround we had to update our documentation to make sure our users use archetype 2.4 explicitly, but that is rather 'backwards' IMO.
          I definitely think these changes in archetype 3.0 should be made optional or at least optionally be turned off.

          rombert Robert Munteanu added a comment -

          +1, our users found out the hard way about this change, and I too will have to explicitly reference 2.4 in the documentation. IMHO it's editing settings.xml "just" for an archetype is more trouble than it's worth, and users would be turned away from that.

          deltoura Amélie Deltour added a comment -

          We are really annoyed by this change as well. The procedure to define a "private" remote catalog in settings.xml is unclear. It should at least be documented.

          Currently the doc still mentions the possibility to use a specific remote catalog using http url:
          http://maven.apache.org/archetype/maven-archetype-plugin/examples/generate-alternative-catalog.html
          https://maven.apache.org/archetype/maven-archetype-plugin/specification/archetype-catalog.html
          https://maven.apache.org/archetype/archetype-models/archetype-catalog/archetype-catalog.html

          In the meantime we will have to revert to version 2.4 of the plugin

          rfscholte Robert Scholte added a comment -

          To support all the features of a standard Maven repository (security, proxy, mirroring), it is best to treat archetype repository as such and to define it as such, no magic.
          We had an equal amount of complaints that archetype didn't work as a repository and that the expected repository features weren't supported.
          I consider this new approach more pure within the Maven eco system.
          However, I think we could help here by introducing a new goal like register-repository, which gives the opportunity to register the archetype repository once. From that moment on there are no extra parameters required related to repositories like you used to.

          sbordet Simone Bordet added a comment - - edited

          Robert, pardon me but I don't understand. Archetype artifacts are stored in Maven Central, and it has always been so.

          The problem here is just a simple XML file, the archetype catalog, that just points to artifacts in Maven central.

          I don't understand what you mean by "archetype repository", and it does not look like it is related to this issue.

          I, for one, do not want another "repository". Maven Central is enough. I just want the ability to run mvn archetype:generate with a pointer to my project so that the user can choose between 1-10 choices and not thousands.

          Can you point to the complains that you mention ?
          Can you also explain the "pureness" you mention, because I feel we are all lost here - the old approach was really "pure" to me, and way simpler.

          Regarding adding the new register-repository goal, I don't know what problems would it solve, and how would make things simpler like they were before.
          And, as I said, I don't want another repository, Maven Central is enough.

          Thanks !

          nielsvk Niels van Kampenhout added a comment -

          I don't think it's a good idea to trade in a large chunk of usability for a perceived increase of "purity" (an ambiguous, vague quality at best).

          When making such a change, please provide sound reasoning in terms of commonly accepted software qualities (maintainability, efficiency, reliability, usability, etc.), and provide an alternative that is at least as good in terms of usability.

          Thanks!

          deltoura Amélie Deltour added a comment -

          I understand the idea behind this to have the catalog resolution more consistent with the Maven eco-system.
          However, the problem here is that when using remote as archetype catalog, Maven Central https://repo.maven.apache.org/maven2/archetype-catalog.xml is searched and not the repositories defined in our settings.xml:

          [DEBUG] Searching for remote catalog: https://repo.maven.apache.org/maven2/archetype-catalog.xml
          

          Adding a repository with id archetype as you suggested does not seem to work either.
          So please explain what is the proper configuration to be able to use our own catalog stored in our internal repository and not in Maven Central.
          If the plugin would resolve remote to search in the repositories already defined in settings.xml I think it would just be fine.

          nthomas Nathan Thomas added a comment - - edited

          As others have stated adding a repository with id archetype does not work, there doesn't seem to be any way to enable this functionality with the current version.

          As a workaround I'm using the previous version of the plugin i.e.:
          mvn org.apache.maven.plugins:maven-archetype-plugin:2.4:generate -DarchetypeCatalog=http://myrepo/archetype-catalog.xml

          rfscholte Robert Scholte added a comment -

          I'm working on ARCHETYPE-522 to ensure that the plugin will connect to mirrors and repositories. Once that's fixed I'll have a look at this issue again.

          kwin Konrad Windszus added a comment -

          What about this now? This has been closed as fixed, but if I understand correctly the only thing being fixed is that URLs now leads to an IAE instead of silently falling back to internal. What about the still valid use case of allowing a user to use a remote catalog without forcing him to meddle around with the settings.xml?

          Also I am wondering how it is possible to support multiple archetype repositories (because they all must have the same id (archetype)).

          hsaputra Henry Saputra added a comment -

          Could we at least re-open this JIRA ticket to continue discussion about what is the right way for getting this resolved?

          shyrkov Sergiy Shyrkov added a comment -

          Guys, now with the release of version 3.0.1, even defining the repository in settings.xml (like suggested in https://issues.apache.org/jira/browse/ARCHETYPE-519?focusedCommentId=15866216&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-15866216) does not work anymore.

          [INFO] ------------------------------------------------------------------------
          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-archetype-plugin:3.0.1:generate (default-cli) on project standalone-pom: archetypeCatalog 'https://devtools.jahia.com/nexus/content/repositories/jahia-releases/archetype-catalog.xml' is not supported anymore. Please read the plugin documentation for details. -> [Help 1]
          

          Seems we've reached here a dead end, Robert Scholte

          rfscholte Robert Scholte added a comment -

          A URL has never been a valid value for archetypeCatalog. I'd suggest to remove that parameter.

          sbordet Simone Bordet added a comment -

          Robert,

          that a URL has never been a valid value for archetypeCatalog is obviously false, since it works fine with 2.4 and it's indeed what everybody here uses in 2.4 as a workaround for the removal of this exact feature in 3.0+.

          So in summary: nobody asked for this feature change, no discussion about it that I could find (please link if there was), it went in as a surprise breaking change in 3.0, the community complains about the 3.0 change in this issue, and there is denial of evidence when people reports the breakage.

          Can you please report the rationale behind this change ? If it was driven by community discussion, is there a link ? Otherwise, why has this change been made, and why there is so much resistance in restoring its functionality when the community asks for it ?

          hsaputra Henry Saputra added a comment -

          I would also seconded all the comments from the community here.

          If "purity" of Maven way is the sole reason the change was made, then I would respectfully ask for revisit of the approach by at least reverting the changes that cause this regression.

          rfscholte Robert Scholte added a comment -

          I've started a thread for it on the dev-list, you can read the responses yourself. Feel free to join the discussion there.

          deltoura Amélie Deltour added a comment -

          I answered to the discussion on the dev-list. I hope my explanation was clear enough.
          It is a pity that we, as users, need to subscribe to a "dev" mailing-list to be able to argue our case. And this issue (ARCHETYPE-519) which is the main issue where users complain about the release was not even mentioned in the thread.

          ilgrosso Francesco Chicchiriccò added a comment -

          I have added above the link to the new mailing list archive on lists.apache.org (based on Apache PonyMail) which eases contributions from non-subscribers.

          hsaputra Henry Saputra added a comment -

          Ah cool, thanks

          deltoura Amélie Deltour added a comment - - edited

          For me it would just be fine without the archetypeCatalog parameter, if the remote catalog could fetch the catalog from the remote repositories defined in settings.xml.
          But this is not the case as described in ARCHETYPE-528.


            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              pmundt Philip Mundt
            • Votes:
              2 Vote for this issue
              Watchers:
              21 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development