Uploaded image for project: 'Maven Archetype'
  1. Maven Archetype
  2. ARCHETYPE-360

Wrong assignment in loop results in wrong debug log output

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.1
    • Component/s: Generator
    • Labels:
      None

      Description

      The "artifactId" parameter in the processFilesetModule() method is reassigned in the while loop iterating over submodules, but the parameter is not used in the loop.

      The only consequence of that is that the artifact ID logged by the getLogger().debug( "Processed " + artifactId ); line at the end of the method does not match the artifact ID logged at the start of the method getLogger().debug( "Processing module " + artifactId ); if there are submodules.

      Proposal: Just delete the line, see attached patch file.

        Activity

        Hide
        hboutemy Hervé Boutemy added a comment -

        patch applied in r1063055
        thank you

        Show
        hboutemy Hervé Boutemy added a comment - patch applied in r1063055 thank you

          People

          • Assignee:
            hboutemy Hervé Boutemy
            Reporter:
            marcwirth Marc Wirth
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development