Uploaded image for project: 'ActiveMQ .Net'
  1. ActiveMQ .Net
  2. AMQNET-377

Sending to non-existent temp queue causes consumer to shutdown

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.5.3, 1.5.4
    • Fix Version/s: 1.5.5, 1.6.0
    • Component/s: ActiveMQ
    • Labels:
      None
    • Environment:

      .NET client on Windows Server 2008 R2

      Description

      It appears as though attempting to send a message to a non-existent temp queue is causing the consumer to shutdown. The behavior manifests itself by either the consumer ceasing to consume messages or, if a request timeout is set, a RequestTimedOutException being thrown. I have an NUnit project attached that I was able to reproduce the issue with. I've also attached logs.

        Attachments

        1. AMQ-NMS.zip
          1.41 MB
          Chris Robison
        2. 2012-04-09.log
          9 kB
          Chris Robison
        3. putty.log
          46 kB
          Chris Robison
        4. activemq.xml
          4 kB
          Chris Robison
        5. NonExistentTempQueueSendTest.cs
          7 kB
          Timothy Bish

          Activity

            People

            • Assignee:
              tabish121 Timothy Bish
              Reporter:
              chrisdrobison Chris Robison
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: