Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-8169

StompNIOSSLTest test fails with more recent JDK 8 versions

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.17.0
    • Fix Version/s: 5.17.0, 5.15.15, 5.16.2
    • Component/s: None
    • Labels:
      None

      Description

      The StompNIOSSL test fails during CI/CD tests with certain JDK versions. This blocks PR's from getting a green status

      To reproduce:

      [x] Fails with jdk1.8.0_281
      [x] Passes with jdk1.8.0_211

      Suspects:

      • The test SSL cert needs to be generated with a newer cipher and/or length
      • The NIOSSLTransport has a bad byte[] read bug

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jbonofre Jean-Baptiste Onofré
                Reporter:
                mattrpav Matt Pavlovich
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 2.5h
                  2.5h