Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-8009

Spring upgrade required for Karaf feature

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: 5.17.0, 5.16.1, 5.15.14
    • Component/s: None
    • Labels:
      None

      Description

      Currently deploying activemq-client in Karaf with Spring 5 fails with:

      osgi.identity; osgi.identity=activemq-client; type=karaf.feature; version="[5.16.0,5.16.0]"; filter:="(&(osgi.identity=activemq-client)(type=karaf.feature)(version>=5.16.0)(version<=5.16.0))" [caused by: Unable to resolve activemq-client/5.16.0: missing requirement [activemq-client/5.16.0] osgi.identity; osgi.identity=spring; type=karaf.feature; version="[4.0.0,5.0.0)"]

      We need to allow Spring 5 here in the feature.

        Attachments

          Activity

            People

            • Assignee:
              coheigea Colm O hEigeartaigh
              Reporter:
              coheigea Colm O hEigeartaigh
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 40m
                40m