Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-7005

Client OSGI bundle without dependencies

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 5.15.4
    • None
    • OSGi/Karaf
    • None
    • Patch Available

    Description

      Current OSGI megabundle activemq-osgi requires many dependencies:

       - spring 4.x (and no 3 or 5)

       - blueprint

       - commons Lang, Pool, Collections

       - Jackson

       

      And many more, in total 20+ bundles for Karaf 4.2.0 and ActiveMQ 5.15.4 .

      It's too much for JMS client module.

       

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              vladimirfx Vladimir Konkov
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h