Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-6649

Add support for MS SQL server JDBC driver 6.1

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 5.14.4
    • 5.15.0, 5.14.5
    • JDBC
    • None

    Description

      activemq-jdbc-store-5.14.4.jar contains support of MS SQL JDBC driver 4.0.
      Could you upgrade to java 8 compliant MS SQL Server JDBC driver 6.1 ?

      As a workaround I have copied file META-INF\services\org\apache\activemq\store\jdbc\microsoft_jdbc_driver_4_0_for_sql_server to META-INF\services\org\apache\activemq\store\jdbc\microsoft_jdbc_driver_6_1_for_sql_server
      This solution is based on AMQ-3914

      Attachments

        Activity

          People

            cshannon Christopher L. Shannon
            josef.broz Josef Bro┼ż
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: