Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-6506

OSGi import ranges for javax.jms should include version 2.0 for activemq-jms-pool

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.14.1
    • Fix Version/s: 5.15.0
    • Component/s: Pool
    • Labels:
      None

      Description

      The import ranges for the ActiveMQ JMS pool bundle should allow, not exclude version 2.0 of the javax.jms API, since JMS 2.0 is backwards compatible with 1.1.

      Should be like in activemq-osgi
      javax.jms;version=[1.1,3)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gtully Gary Tully
                Reporter:
                graben Benjamin Graf
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: