Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-6355

Provide bundles for activemq-client and its dependencies

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.13.3
    • Fix Version/s: 5.14.0
    • Component/s: JMS client
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      I need to install activemq client on plain felix. Of course I can use the karaf feature and install all bundles from it. This is quite hughe though.

      So I tried to install the activemq-client and just its dependencies. Interestingly activemq does not seem to produce bundles during the build.
      This is especially strange as some of the projects even include custom maven bundle plugin settings.

      The reason seems to be that the packaging type bundle is missing.
      I will provide a PR to adjust the bundles needed for the activemq client.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cshannon Christopher L. Shannon
                Reporter:
                cschneider Christian Schneider
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: