Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-6298

Incorrect Import-Package version range for org.springframework.osgi

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • 5.13.0, 5.13.1, 5.13.2, 5.13.3
    • 5.13.4, 5.14.0
    • OSGi/Karaf
    • Patch Available
    • Regression
    • Patch

    Description

      In issue AMQ-5922, I supplied a patch that updated the OSGi version range inside activemq-osgi for Spring to include Spring 4.X. Unfortunately, I reordered the "org.springframework*" clause and this is causing the version range for Spring and Spring-DM classes to be set to "[3,5)".

      This is not a correct version range for Spring-DM since its releases only went from 1.0 to several 2.0 candidates.

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            davsclaus Claus Ibsen
            soleger Seth Leger
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment