ActiveMQ
  1. ActiveMQ
  2. AMQ-4308

HttpsTransportBrokerTest hangs occasionally

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Test Cases
    • Labels:
      None
    • Patch Info:
      Patch Available

      Description

      This test occasionally hangs, causing the build to hang. I haven't been able to reproduce it yet, but have seen it several times on the Fuse Hudson instance. I'll attach a patch which adds a timeout.

      1. AMQ4308.patch
        3 kB
        Kevin Earls
      2. HttpsTransportBrokerTestStack.txt
        23 kB
        Kevin Earls

        Issue Links

          Activity

          Kevin Earls added a comment -

          I can no longer reproduce thist.

          Kevin Earls added a comment -

          I don't think I've seen it recently. I'll try this afternoon and close this if I can't reproduce it.

          Timothy Bish added a comment -

          Kevin, have you seen any failures from this test in awhile. We updated the HttpClient to the latest patch release right before 5.8.0 and I'm wondering if this was fixed as part of that. The stack trace shows the lock happens down in the HttpClient stack so its possible. I've been running the test repeatedly this morning but so far can't reproduce.

          Timothy Bish added a comment -

          These are both stuck on the same bit of code, shutdown while processing incoming requests.

          Kevin Earls added a comment -

          I was able to reproduce the hang, this is the stack trace

          Timothy Bish added a comment -

          Patch applied


            People

            • Assignee:
              Unassigned
              Reporter:
              Kevin Earls
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development