Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-3956

KahaDB pagefile (db.data) steady growth - BTreeIndex page leak

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.5.1, 5.6.0
    • Fix Version/s: 5.7.0
    • Component/s: None
    • Labels:

      Description

      There is a page leak in the kahadb BTeeIndex that can result in the pagefile (db.data) growing steadily. One use case that can reproduce is with durable subs that repeatedly subscribe and unsubscribe with pending messages.
      The problem can occur with particular usage of any btree index so the problem is not confined to durable subs.

        Activity

        gtully Gary Tully added a comment -
        ravisomepalli Ravi Somepalli added a comment -

        We have 5.7.0 and use only persistent queues this issue is failing

        gtully Gary Tully added a comment -

        If you can provide a unit test that demos the problem on trunk. Please reopen this issue.


          People

          • Assignee:
            gtully Gary Tully
            Reporter:
            gtully Gary Tully
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development