Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.5.0
    • Component/s: None
    • Labels:
      None

      Description

      ActiveMQ 5.4.x uses Karaf 2.1.0.

      Karaf 2.2.0 will be released soon. A change affects ActiveMQ: a new Felix gogo version.

      For instance, if you try to deploy ActiveMQ 5.4.2 on Karaf 2.1.99-SNAPSHOT, you will get an unresolved constraint as the Felix Gogo export package changed.

      In preparation for the support of Karaf 2.2.0, I'm gonna submit a patch to update the Import-Package and use the corresponding Gogo version.

      1. AMQ3142.patch
        6 kB
        Andreas Pieber

        Activity

        Hide
        Dan Tran added a comment -

        Hi JB, is there a way to manually patch activemaq 5.4 to get this issue fixed ( while waiting for official fix 5.5? )

        Thanks

        Show
        Dan Tran added a comment - Hi JB, is there a way to manually patch activemaq 5.4 to get this issue fixed ( while waiting for official fix 5.5? ) Thanks
        Hide
        Andreas Pieber added a comment -

        I've patched AMQ to run smoothly on karaf-2.2.0. @Dan: Feel free to give the patch attached to this issue a try and report your feedback

        Show
        Andreas Pieber added a comment - I've patched AMQ to run smoothly on karaf-2.2.0. @Dan: Feel free to give the patch attached to this issue a try and report your feedback
        Hide
        Dejan Bosanac added a comment -

        Patched applied with svn revision 1077868. Thanks!

        Show
        Dejan Bosanac added a comment - Patched applied with svn revision 1077868. Thanks!
        Hide
        Dejan Bosanac added a comment -

        I'm trying now to make 5.5.0 work with both karaf 2.1.x and 2.2.0 and newer, but have some difficulties at the moment. I created a separate features for 2.1.x.

        But trying to do:

        karaf@root> features:addUrl mvn:org.apache.activemq/activemq-karaf/5.5-SNAPSHOT/xml/features-2.1
        karaf@root> features:install activemq-spring 
        

        gets

        Error executing command: Could not start bundle mvn:org.apache.activemq/activemq-karaf/5.5-SNAPSHOT in feature(s) activemq-5.5-SNAPSHOT: Unresolved constraint in bundle activemq-karaf [64]: Unable to resolve 64.0: missing requirement [64.0] package; (&(package=org.apache.felix.gogo.commands)(version>=0.6.0)(!(version>=1.0.0)))
        

        I tried manually adding gogo commands and runtime (v 0.8.0) but with no luck. Can someone else take a look at it, as I might missing something obvious.

        Show
        Dejan Bosanac added a comment - I'm trying now to make 5.5.0 work with both karaf 2.1.x and 2.2.0 and newer, but have some difficulties at the moment. I created a separate features for 2.1.x . But trying to do: karaf@root> features:addUrl mvn:org.apache.activemq/activemq-karaf/5.5-SNAPSHOT/xml/features-2.1 karaf@root> features:install activemq-spring gets Error executing command: Could not start bundle mvn:org.apache.activemq/activemq-karaf/5.5-SNAPSHOT in feature(s) activemq-5.5-SNAPSHOT: Unresolved constraint in bundle activemq-karaf [64]: Unable to resolve 64.0: missing requirement [64.0] package ; (&( package =org.apache.felix.gogo.commands)(version>=0.6.0)(!(version>=1.0.0))) I tried manually adding gogo commands and runtime (v 0.8.0) but with no luck. Can someone else take a look at it, as I might missing something obvious.
        Hide
        Andreas Pieber added a comment -

        This is strange. I'm sure I've already fixed this. Could you please locally apply my second patch @AMQ-3207, build locally and try again?

        Show
        Andreas Pieber added a comment - This is strange. I'm sure I've already fixed this. Could you please locally apply my second patch @ AMQ-3207 , build locally and try again?
        Hide
        Dejan Bosanac added a comment -

        This is now solved by using older (5.4.2) activemq-karaf for older versions. It's also documented here

        https://cwiki.apache.org/confluence/display/ACTIVEMQ/OSGi+Integration

        Thanks to Andreas for suggestion

        Show
        Dejan Bosanac added a comment - This is now solved by using older (5.4.2) activemq-karaf for older versions. It's also documented here https://cwiki.apache.org/confluence/display/ACTIVEMQ/OSGi+Integration Thanks to Andreas for suggestion

          People

          • Assignee:
            Dejan Bosanac
            Reporter:
            Jean-Baptiste Onofré
          • Votes:
            1 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development