Uploaded image for project: 'ActiveMQ'
  1. ActiveMQ
  2. AMQ-2170

Incoherent documentation / strange property names for advisory messages

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.2.0
    • Fix Version/s: 5.7.0
    • Component/s: Documentation
    • Labels:
      None

      Description

      http://activemq.apache.org/per-destination-policies.html says that the advisory messages available for a destination are
      advisoryForConsumed
      advisoryForDelivered
      advisoryForDiscardedMessages
      advisoryForSlowConsumers
      advsioryForFastProducers
      advisoryWhenFull

      However, the page at http://activemq.apache.org/advisory-message.html says
      advisoryForConsumed
      advisoryForDelivery (different)
      advisoryForDiscardingMessages (different)
      advisoryForSlowConsumers
      advisdoryForFastProducers (different)
      advisoryWhenFull

      The two pages should say the same thing (currently the 2nd page matches the code); and you should also consider changing the name of 'advisdoryForFastProducers' to be 'advisoryForFastProducers' in the code and the documentation to remove the typo.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rgibson Robert Gibson
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: