ActiveMQ
  1. ActiveMQ
  2. AMQ-1644

Using NON_PERSISTENT delivery mode increases MemoryPercentageUsed to 100% and block sending

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 5.0.0
    • Fix Version/s: 5.1.0
    • Component/s: JMS client
    • Labels:
      None

      Description

      I'm creating pub/sub application and when I set the DeliveryMode to NON_PERSISTENT in the message produce, the MemoryPercentageUsed increased until it reached 100% and the send will be blocked on waitForSpace().

      For the same application if I set the DeliveryMode to PERSISTENT, every thing works fine and MemoryPercentageUsed remains at 0%

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        1d 19h 53m 1 Hiram Chirino 09/Apr/08 14:00
        Jeff Turner made changes -
        Project Import Fri Nov 26 22:32:02 EST 2010 [ 1290828722158 ]
        Hiram Chirino made changes -
        Field Original Value New Value
        Fix Version/s 5.1.0 [ 11802 ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Hide
        Hiram Chirino added a comment -

        There was some bad usage accounting in 5.0 which has now been fixed. Should make it into the 5.1 release. Please re-test against trunk if you get a chance.

        Show
        Hiram Chirino added a comment - There was some bad usage accounting in 5.0 which has now been fixed. Should make it into the 5.1 release. Please re-test against trunk if you get a chance.
        Mina Nesiem created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Mina Nesiem
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development