Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-25397

Upgrading ambari-logsearch-logfeeder to 2.7.4 rpm gives warnings

    XMLWordPrintableJSON

    Details

      Description

      Customer is upgrading Ambari Logsearch to 2.7.4, while upgrading the rpm it gives below errors/warnings

      ln: failed to create symbolic link '/usr/bin/logfeeder': File exists
      rm: cannot remove '/etc/ambari-logsearch-logfeeder': Is a directory
      warning: %postun(ambari-logsearch-logfeeder-2.7.4.*noarch) scriptlet failed, exit status 1
      
      • The issue can be reproduced in local environment
      • Also the symlink for file "/usr/bin/logfeeder" does not get created since Ambari 2.7.4
        In Ambari 2.7.3 the symlink is created

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                sziszo Szilard Antal
                Reporter:
                sziszo Szilard Antal
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 0.5h
                  0.5h