Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-20212

Remove HDP version check in KAFKA service

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 2.5.0
    • ambari-server
    • None

    Description

      Need to fix following code in KAFKA.

            if compare_versions(src_version, '2.3.4.0') < 0 and compare_versions(dst_version, '2.3.4.0') >= 0:
              # Calling the acl migration script requires the configs to be present.
              self.configure(env, upgrade_type=upgrade_type)
              upgrade.run_migration(env, upgrade_type)
      

      Attachments

        1. AMBARI-20212_addendum.patch
          0.6 kB
          Madhuvanthi Radhakrishnan
        2. AMBARI-20212.patch
          2 kB
          Madhuvanthi Radhakrishnan
        3. AMBARI-20212_trunk.patch
          3 kB
          Madhuvanthi Radhakrishnan

        Issue Links

          Activity

            People

              mradhakrishnan Madhuvanthi Radhakrishnan
              mradhakrishnan Madhuvanthi Radhakrishnan
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: