Uploaded image for project: 'Ambari'
  1. Ambari
  2. AMBARI-19740

Ambari upgrade to Ambari 2.5 causes start DB check failure on Zeppelin configs

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Resolved
    • Major
    • Resolution: Fixed
    • None
    • 2.5.0
    • None
    • None

    Description

      Ambari upgrade to Ambari 2.5 causes start DB check failure on Zeppelin configs:

      017-01-11 15:50:16,078  INFO - Comparing required service configs from stack with mapped service configs from db
      2017-01-11 15:50:16,084 ERROR - Required config(s): zeppelin-log4j-properties,zeppelin-shiro-ini is(are) not available for service ZEPPELIN with service config version 3 in cluster c1
      2017-01-11 15:50:16,084  INFO - Getting services which has mapped configs which are not selected in clusterconfigmapping
      

      HDP version 2.5 was not upgraded.

      Steps to reproduce

      1. Install Ambari 2.4.2
      2. Create cluster using HDP 2.5 - including Zeppelin
      3. Enable Kerberos (probably not necessary)
      4. Upgrade Ambari to 2.5.0
      5. Attempt to start Ambari
      6. See error message in /var/log/ambari-server/ambari-server-check-database.log

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            rkamath Renjith Kamath
            rkamath Renjith Kamath
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment